[Redirected] Opening a virtual machine console from vSphere Client fails with the error: Unable to contact the MKS
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[Redirected] Opening a virtual machine console from vSphere Client fails with the error: Unable to contact the MKS

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Article ID: 339719

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Opening a virtual machine console from vSphere Client initially fails with the error similar to:

    Cannot open/create log file 'C:\Users\Administrator\AppData\Local\Temp\1\vmware-Administrator\vmware-xxx-mks-C:\yyyyyyy.log': The filename, directory name, or volume label syntax is incorrect

    Unable to open log file
    "C:\Users\Administrator\AppData\Local\Temp\1\vmware-Administrator\vmware-xxx-mks-C:\yyyyyyy.log". Check your configuration to make sure that the path specified for the log file is valid, and that you have write privileges in this directory.
    Unable to proceed without a log file.

     
  • Subsequent attempts to open a virtual machine console fail with the error:
     
    • vSphere Client 4.x:

      Unable to contact the MKS: Could not connect to pipe\\.\pipe\vmware-authdpipe: The system cannot find the file specified
       
    • vSphere Client 5.0:

      Unable to connect to the MKS: Host address lookup for server <esxi.domain.com> failed: No such host is known
      The VMRC console has disconnected...attempting to reconnect

       
  • After triggering the event, in the viclient.log file, you see entries similar to:

    [ :QuickInf:M:14] <YYYY-MM-DD>T<time>.945 EmbeddedVMRC::Creating a new console
    [viclient:SoapTran:W:17] <YYYY-MM-DD>T<time>.950 Invoke 141 Finish WaitForUpdates on PropertyCollector:propertyCollector [vc-10-ah] - Serial:0.000, Server:000.110
    [viclient:SoapTran:P:27] <YYYY-MM-DD>T<time>.950 Invoke 143 Finish CreateFilter on PropertyCollector:propertyCollector [vc-10-ah] - Serial:0.000, Server:000.004 [session[5283872a-f284-845b-c12a-9779e19bcc11]52eb3b66-97ef-f02e-ee2b-1f40d3e4b456]
    [viclient:SoapTran:M:14] <YYYY-MM-DD>T<time>.064 Invoke 144 Start GetAlarmActionsEnabled on AlarmManager:AlarmManager [vc-10-ah]. [operationID:5635AC17-00000090][Caller: VpxClient.InventoryContextMenus.SetAlarmContextMenuItems]
    [viclient:SrvMsg :M:14] <YYYY-MM-DD>T<time>.064 RMI Request Vmomi.Alarm.AlarmManager.GetAlarmActionsEnabled - 144
    VirtualMachine:vm-379 [vc-10-ah]
    [viclient:SoapTran:P:27] <YYYY-MM-DD>T<time>.068 Invoke 144 Finish GetAlarmActionsEnabled on AlarmManager:AlarmManager [vc-10-ah] - Serial:0.000, Server:000.004
    [viclient:QuickInf:W:17] <YYYY-MM-DD>T<time>.092 WaitForUpdates Version = 34
    [viclient:SoapTran:W:17] <YYYY-MM-DD>T<time>.092 Invoke 145 Start WaitForUpdates on PropertyCollector:propertyCollector [vc-10-ah]. [operationID:5635AC17-00000091]
    [viclient:SrvMsg :W:17] <YYYY-MM-DD>T<time>.092 RMI Request Vmomi.Core.PropertyCollector.WaitForUpdates - 145
    34
    </time></time></time></time></time></time></time></time></time>

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

    Note: For more information on log locations, see Collecting diagnostic information for the vSphere Client or VMware Infrastructure Client (1003687).


Environment

VMware vCenter Server 5.0.x
VMware ESXi 3.5.x Installable
VMware ESX 4.0.x
VMware vCenter Server 5.1.x
VMware vSphere ESXi 5.0
VMware ESXi 4.1.x Installable
VMware vCenter Server 4.0.x
VMware vCenter Server 4.1.x
VMware ESX 4.1.x
VMware ESX Server 3.5.x
VMware ESXi 4.0.x Installable

Cause

This issue occurs when a custom environment variable named User is set in Windows on the vSphere Client machine.

Resolution

To resolve this issue, remove the environment variable from the vSphere Client machine or vCenter Server:
 
  1. Click Start > Run, type sysdm.cpl, and press Enter. The System Properties window opens.
  2. Click the Advanced tab.
  3. Click Environment Variables.
  4. Remove any user variable and any system variable named User.
  5. Reboot Windows and launch vSphere Client.
If the issue persists, end any vmware-vmrc.exe processes in the Windows Task Manager:
  1. Close all vSphere Client sessions.
  2. Open Windows Task Manager.
  3. Search for any vmware-vmrc.exe processes and end the process.
  4. Start the vSphere Client and connect to the host directly or to vCenter Server.
Note: If your problem persists after trying the steps in this article, file a Support Request with VMware Support and note this Knowledge Base article ID (2032016) in the problem description. For more information, see Filing a Support Request in My VMware (2006985).

Additional Information

For more information on similar error to this article, see: For other related information, see Identifying issues with and setting up name resolution on ESX/ESXi Server (1003735).Collecting diagnostic information for the vSphere Client or VMware Infrastructure Client
Identifying issues with and setting up name resolution on ESX/ESXi Server
How to file a Support Request in My VMware
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