"Unable to connect to MKS" error in vSphere Web Client
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"Unable to connect to MKS" error in vSphere Web Client

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Article ID: 340214

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Launching a virtual machine console from the vSphere Web Client or vSphere Client fails.
  • You see one of these errors.
    • Unable to connect to the MKS: Could not connect to pipe \\.\pipe\vmware-authdpipe within retry period.
    • Unable to connect to MKS: internal error
  • In the /vmfs/volumes/datastore/virtual_machine/vmware.log file, located in the virtual machines directory, you see entries similar to:
<YYYY-MM-DD>T<TIME>| mks| I120: SOCKET 5 (122) recv error 104: Connection reset by peer
<YYYY-MM-DD>T<
TIME>| mks| I120: SOCKET 5 (122) VNC Remote Disconnect.
<YYYY-MM-DD>T<
TIME>| mks| W110: SSL: Unknown SSL Error
<YYYY-MM-DD>T<
TIME>| mks| I120: SSL Error: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
<YYYY-MM-DD>T<
TIME>| mks| I120: SSL Error: error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
 
  • In the /var/log/hostd.log file, you see entries similar to:

    <YYYY-MM-DD>T<TIME> info hostd[28CC1B70] [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/5524009b-6ab4ce54-6fb0-001a64dda48a/vc/vc.vmx opID=fe5a38b5-5f95-4ca5-83f5-df6def1268f3-199-ngc-a8-33-db97 user=vpxuser:<domain>\Administrator] Ticket issued for mks service to user: vpxuser
    [LikewiseGetDomainJoinInfo:355] QueryInformation(): ERROR_FILE_NOT_FOUND (2/0)


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
     
  • When migrating an ESXi host to a new vCenter Server, the SSL certificate may change.


Environment

VMware vCenter Server 6.0.x
VMware vSphere ESXi 6.0

Cause

This issue occurs because an ESXi host is not placed in maintenance mode before migrating to a different vCenter Server.
 
 

Resolution

This issue is resolved in VMware ESXi 6.0 Update 2, available at VMware Download


Workaround:
To work around this issue, refresh the VMX/MKS SSL cache on the virtual machine by migrating the virtual machine to another ESXi host.
 
If migrating the virtual machine does not resolve the issue, reboot the ESXi host.

To reboot the ESXi host:
  1. Power off the affected virtual machine.
  2. Place the ESXi host into maintenance mode.
  3. Restart the ESXi host.


Additional Information

For more information, see: