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Horizon-workspace restart causes vRA services to fail in HA environment (2150587)

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Symptoms

  • Your vRealize Automation Environment is in a High Availability configuration.
  • You performed a failover or otherwise shutdown the horizon-workspace service on at least one of the vRA nodes.
  • In the horizon-workspace logs, you see an error similar to the following:

    Error creating bean with name
      'liquibase' defined in class path resource [spring/datastore-wireup.xml]:
      Invocation of init method failed; nested exception is
      liquibase.exception.LockException: Could not acquire change log lock. Currently
      locked by fe80:0:0:0:250:56ff:fea8:7d0c%eth0
      (fe80:0:0:0:250:56ff:fea8:7d0c%eth0) since 10/29/15

Cause

This issue occurs when the Identity Manager fails to start in a high availability environment because of issues with the liquibase data management utility used by vRealize Automation.

Resolution

This is a known issue affecting VMware vRealize Automation 7.x. For more information see, Directories Management Identity Manager Fails to Start After Horizon-Workspace Restart section of the Installing and Upgrading vRealize Automation guide.
 
Currently, there is no resolution.
 
To work around this issue:
  1. Log in using root credentials to a console session on the vRealize Automation appliance.
  2. Stop the horizon-workspace service by running the command:

    #service horizon-workspace stop

  3. Open the postgres shell as super user:

    su postgres

  4. Navigate to the correct bin directory by running the command:

    cd /opt/vmware/vpostgres/current/bin

  5. Connect to the database by running the command:

    psql vcac

  6. Run the SQL query:

    select * from saas.databasechangeloglock;


    If the output shows a value of t for true, the lock must be released manually.
  7. If you need to manually release the lock, run the SQL query:

    update saas.databasechangeloglock" set locked=FALSE, lockgranted=NULL, lockedby=NULL where id=1;

  8. From saas.databasechangeloglock, run the SQL query:

    select * from databasechangeloglock;


    The output should show a value of f for false, meaning it is unlocked.
  9. Exit the postgres vcac database by running the command:

    vcac=# \q

  10. Close the postgres shell by running the command:

    exit

  11. Start the horizon-workspace service by running the command:

    #service horizon-workspace start

Impact/Risks

For any manual changes to the vRA database, VMware recommends taking a backup of the database prior to proceeding to provide a fallback point in case it's needed.
 
For instructions on how to backup the vPostgres database, see How to backup or export embedded Postgres DB from vRealize Automation appliance (2074214)

Tags

vRealize Automation, High Availability, VMware Identity Manager, horizon-workspace, horizon workspace, services fail

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