Search the VMware Knowledge Base (KB)
View by Article ID

Connection to iSCSI Datastore is lost with the error "(inaccessible)" (2151403)

  • 0 Ratings

Symptoms

  • Connection to iSCSI Datastore is lost with the error (inaccessible).

  • In the /var/log/vmkernel.log file, you see entries similar to:

    2017-03-14T08:15:19.484Z cpu12:69640)Tcpip: 2998: msleep returned 4
    2017-03-14T08:15:19.572Z cpu16:69640)iscsi_vmk: iscsivmk_ConnNetRegister: socket 0x43072c894850 network resource pool netsched.pools.persist.iscsi associated
    2017-03-14T08:15:19.572Z cpu16:69640)iscsi_vmk: iscsivmk_ConnNetRegister: socket 0x43072c894850 network tracker id 940406530 tracker.iSCSI.10.168.51.2 associated
    2017-03-14T08:15:19.823Z cpu17:69640)WARNING: iscsi_vmk: iscsivmk_StartConnection: vmhba64:CH:0 T:7 CN:0: iSCSI connection is being marked "ONLINE"
    2017-03-14T08:15:19.823Z cpu17:69640)WARNING: iscsi_vmk: iscsivmk_StartConnection: Sess [ISID: 00023d000001 TARGET: iqn.2009-10.com.osnexus:20e334c8-cb39862e2fdbd5b7:MHS551 TPGT: 1 TSIH: 0]
    2017-03-14T08:15:19.823Z cpu17:69640)WARNING: iscsi_vmk: iscsivmk_StartConnection: Conn [CID: 0 L: 10.168.51.115:35374 R: 10.168.51.2:3260]
  • In the /var/log/vobd.log file, you see entries similar to:

    2017-03-14T08:15:26.909Z: [iscsiCorrelator] 6967022647679us: [vob.iscsi.target.connect.error] vmhba64 @ vmk2 failed to login to iqn.2009-10.com.osnexus:20e334c8-cb39862e2fdbd5b7:MHS551 because of a network connection failure.
    2017-03-14T08:15:26.910Z: [iscsiCorrelator] 6967053597349us: [esx.problem.storage.iscsi.target.connect.error] Login to iSCSI target iqn.2009-10.com.osnexus:20e334c8-cb39862e2fdbd5b7:MHS551 on vmhba64 @ vmk2 failed. The iSCSI initiator could not establish a network connection to the target.
    2017-03-14T08:15:26.911Z: [iscsiCorrelator] 6967022648151us: [vob.iscsi.target.connect.error] vmhba64 @ vmk3 failed to login to iqn.2009-10.com.osnexus:20e334c8-cb39862e2fdbd5b7:MHS551 because of a network connection failure.=


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs when you use port binding with VMkernel ports which are on different subnets.

Resolution

To resolve the issue, remove the VMkernel ports from port binding on all hosts if they are on different subnets. 

  1. Migrate all Virtual machines to other ESXi hosts.

  2. Put the ESXi host into Maintenance mode.

  3. Unmount all iSCSI datastores.

    Note: Ensure to just unmount the datastores, do not delete them.

  4. Remove the vmkernel ports from port binding.

    Note: When you get prompted that you are about to remove the last vmkernel port from the setup, click YES.

  5. Perform a storage rescan.

  6. Reboot the ESXi host.

  7. Exit the host from maintenance mode.

  8. Migrate VMs from other host to the updated host and repeat the process for other hosts.

Note: All VMkernel ports used for iSCSI connectivity must reside in the same broadcast domain and IP subnet. For more information, see Considerations for using software iSCSI port binding in ESX/ESXi (2038869).

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: