Search the VMware Knowledge Base (KB)
View by Article ID

Keystone errors when attempting to synchronize the Availability Zone after initial deployment in VIO (2150663)

  • 1 Ratings

Symptoms

  • Initial deployment authentication service (keystone) errors when attempting to synchronize the Availability Zone in VMware Integrated OpenStack (VIO).
  • In the keystone.log file, you see entries similar to:

    23950 TRACE keystone.common.wsgi     return conn.result3(msg_id, all, timeout)
    23950 TRACE keystone.common.wsgi   File "/usr/lib64/python2.7/site-packages/ldap/ldapobject.py", line 469, in result3
    23950 TRACE keystone.common.wsgi     resp_ctrl_classes=resp_ctrl_classes
    23950 TRACE keystone.common.wsgi   File "/usr/lib64/python2.7/site-packages/ldap/ldapobject.py", line 476, in result4
    23950 TRACE keystone.common.wsgi     ldap_result = self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
    23950 TRACE keystone.common.wsgi   File "/usr/lib64/python2.7/site-packages/ldap/ldapobject.py", line 99, in _ldap_call
    23950 TRACE keystone.common.wsgi     result = func(*args,**kwargs)
    23950 TRACE keystone.common.wsgi OPERATIONS_ERROR: {'desc': 'Operations error'}
    23950 ERROR keystone.common.wsgi OPERATIONS_ERROR: {'info': '000004DC: LdapErr: DSID-0C090752, comment: In order to perform this operation a successful bind must be completed on the connection., data 0, v2580', 'desc': 'Operations error'}

Cause

This issue occurs when keystone is using Active Directory back-end. When keystone is using Active Directory back-end, it not possible to authenticate to VMware Integrated OpenStack.

Resolution

To resolve this issue:
  1. Open the /etc/keystone/keystone.conf file using a text editor.
  2. In the ldap section, locate the entry:

    * chase_referrals

  3. Change the chase_referrals value from True to False:

    chase_referrals = False

  4. Save the file and close.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 1 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 1 Ratings
Actions
KB: