Search the VMware Knowledge Base (KB)
View by Article ID

Unable to start Web Client service after upgrade (2150318)

  • 0 Ratings

Symptoms

  • vSphere Web Client service won't start after an upgrade of a Windows based vCenter/Web Client server or a vCenter Server Appliance.
  • When trying to start the service, in the wrapper.log you see similar errors to:
WARN   | wrapper  | <YYYY-MM-DD>T<TIME> | Encountered an invalid numerical value for configuration property wrapper.java.initmemory=1024m.  Resolving to 1024.
WARN   | wrapper  | <YYYY-MM-DD>T<TIME> | Encountered an invalid numerical value for configuration property wrapper.java.maxmemory=2048m.  Resolving to 2048.
STATUS | wrapper  | <YYYY-MM-DD>T<TIME> | Launching a JVM...
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | WrapperManager: Initializing...
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.988] [INFO ] startup-tracker               <KE0001I> Kernel starting.
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.582] [INFO ] startup-tracker               <KE0002I> Kernel started.
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.597] [ERROR] system-artifacts              <DE0700E> Cannot find bundle 'com.vmware.help' version range '[0.0.0, oo)' in repository 'ext-usr'.
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.597] [ERROR] system-artifacts              <DE0700E> Cannot find bundle 'com.vmware.store' version range '[0.0.0, oo)' in repository 'ext-usr'.
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.597] [ERROR] system-artifacts              <DE0700E> Cannot find bundle 'com.vmware.dataservices' version range '[0.0.0, oo)' in repository 'ext-usr'.
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.597] [ERROR] system-artifacts              <DE0700E> Cannot find bundle 'com.vmware.vimservices' version range '[0.0.0, oo)' in repository 'ext-usr'.
INFO   | jvm 1    | <YYYY-MM-DD>T<TIME> | [<YYYY-MM-DD>T<TIME>.597] [ERROR] system-artifacts              <DE0700E> Cannot find bundle 'com.vmware.vim.dataserviceadapters' version range '[0.0.0, oo)' in repository 'ext-usr'.

Cause

  • The Web Client "work" folder is like a cache where required plugins and UI related files are stored.
  • It will be created during a fresh install of the client.
  • When a minor upgrade is performed the 'work' folder should be deleted which is not happening in the environment.

Resolution

To resolve the issue, take a snapshot of the VCSA or Windows machine where the Web Client server is located and rename or remove the 'work' folder which can be found at:

VCSA:
/usr/lib/vmware-vsphere-client/server/

Windows Server:
"C:\Program Files\VMware\Infrastructure\vSphereWebClient\server"

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: