Search the VMware Knowledge Base (KB)
View by Article ID

Managing NSX Edge from vCloud Director fails after upgrading vCNS 5.5.3 to NSX for vSphere 6.2.x (2150069)

  • 0 Ratings
Language Editions

Symptoms

After upgrading vCNS 5.5.x to NSX for vSphere 6.2.x in a vCloud Director environment, you experience these symptoms:
  • Managing the NSX Edge fails
  • Deleting a network in vCloud Director fails
  • In the NSX Edge, you see errors similar to:

    [ 5504a62f-b3bc-4bdd-ade6-98c2c2aae77c ] Cannot deploy organization VDC network (5c7f9d6b-0f09-4d67-9dbe-ac72dbff5270)
    Failed to connect interface of edge gateway edge_ccs9764 to organization VDC network test
    java.util.concurrent.ExecutionException: com.vmware.vcloud.fabric.nsm.error.VsmException: VSM response error (100): null
    - Failed to connect interface of edge gateway edge_ccs9764 to organization VDC network test
    java.util.concurrent.ExecutionException: com.vmware.vcloud.fabric.nsm.error.VsmException: VSM response error (100): null
    - java.util.concurrent.ExecutionException: com.vmware.vcloud.fabric.nsm.error.VsmException: VSM response error (100): null
    - com.vmware.vcloud.fabric.nsm.error.VsmException: VSM response error (100): null
    - VSM response error (100): null
  • Running the show log manager command on the NSX Manager displays entries similar to:

    2017-04-26 16:41:53.404 GMT INFO http-nio-127.0.0.1-7441-exec-6 AuditingServiceImpl:147 - [AuditLog] UserName:'admin', ModuleName:'NSX Edge Vnic', Operation:'CONFIG UPDATE', Resource:'vse-edge_ccs4679 (08e03e2c-28d0-4ee7-854d-85ae27f26346)', Time:'Wed Apr 26 16:41:53.400 GMT 2017', Status:'FAILURE', Universal Object:'false'
    2017-04-26 16:41:53.410 GMT ERROR http-nio-127.0.0.1-7441-exec-6 BaseRestController:406 - REST API failed : 'null'
    java.lang.NullPointerException
    at com.vmware.vshield.edge.systemcontrol.service.SystemControlServiceImpl.getSysctlConfig_aroundBody8(SystemControlServiceImpl.java:150)
    at com.vmware.vshield.edge.systemcontrol.service.SystemControlServiceImpl$AjcClosure9.run(SystemControlServiceImpl.java:1)
    at org.aspectj.runtime.reflect.JoinPointImpl.proceed(JoinPointImpl.java:149)
    at com.vmware.vshield.vsm.aspects.security.VsmSecuredAspect.secureCheck(VsmSecuredAspect.java:126)
  • In vCloud Director cell, you see entries similar to:

    vcloud-container-debug.log:2017-04-27 10:03:44,380 | WARN | nf-activity-pool-1450 | LoggingRestTemplate |
    PUT request for "https://1.1.1.1:443/api/3.0/edges/edge-30/vnics/1"
    resulted in 500 (Internal Server Error); invoking error handler | requestId=28469838-d5e5-4178-8769-a68df2d1e7d6,
    request=POST https://es.vcloud.colt.net/cloud/amf,requestTime=1493283813272,remoteAddress=192.255.96.164:22972,userAgent=Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36
    (KHTML...,accept=*/* method=networkService.createOrgVdcNetwork vcd=e59a3a81-b573-4c23-a500-44b4ea118129,task=ed86d300-7cfb-4a31-b79f-2093841d632e
    activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:ed86d300-7cfb-4a31-b79f-2093841d632e)
    activity=(com.vmware.vcloud.fabric.net.activities.gateway.AddGatewayInterfaceAndConfigureVnicActivity,urn:uuid:88f7e03a-8eae-4454-98be-eafaeacf4414)
    activity=(com.vmware.vcloud.fabric.net.activities.gateway.GenerateGatewayInterfaceBackingActivity,urn:uuid:88f7e03a-8eae-4454-98be-eafaeacf4414)


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs because the Edge is still in an older version (For example: 5.5.1, 5.5.2, 5.5.3) of vCNS. This makes the Edge unmanageable from vCloud Director.

Note:When an Edge is re-deployed after the upgrade, the version is changed to 5.5.4.x. This version can be managed with vCloud Director.

Resolution

To resolve this issue, upgrade vCNS 5.5.3 to the latest version available. When the upgrade is complete, upgrade vCNS to NSX for vSphere 6.x. For more information, see the VMware Product Interoperability Matrices.

See Also

Language Editions

ja,2150863;zh_cn,2150972

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: