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Trouble backing up vSAN and VVol datastores with VDP 6.1.3 or VADP 6.5 (2149271)

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Symptoms

VMware Data Protection (VDP) 6.1.3 and other backup software based on VDDK 6.5 may appear to stall out before  completion. Upon examination, the backup process has crashed and the job must be cancelled. With some software, the ESXi host loses connectivity and enters a "not responding" state. Taking a snapshot could throw the error "you do not have access rights to this file."

Cause

This happens with VVol and vSAN datastores when the backup software has selected SAN transport, which is not supported for VVol and vSAN. The backup software selects this transport either because SAN was explicitly chosen, or because software accepted SAN as the default transport. In earlier releases this was not an issue, but in VDDK 6.5 the default value is not correctly interpreted for a virtual backup proxy.

Resolution

A fix has been identified and will be in a future VDDK 6.5 update release, but might not appear for VDP.

There a workaround. For a virtual proxy, find the backup software configuration file and add the following line to disable checking for default transport mode:
vixDiskLib.transport.san.DisableVmCheck=0

For VDP, /usr/local/avamarclient/var/vddkconfig.ini is the configuration file.

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