Search the VMware Knowledge Base (KB)
View by Article ID

VMware vCenter Server 6.0 U3 SDK and CLI support (2149213)

  • 0 Ratings

Symptoms

  • SDK communication with vCenter Server or ESX might fail when the vCenter Server system is configured to use the TLSv1.1 and TLSv1.2 protocols.
  • vCLI/ESXCLI/PowerCLI communication with vCenter Server or ESX might fail when the vCenter Server system is configured to use the TLSv1.1 and TLSv1.2 protocols.

Cause

TLSv1.1 and TLSv1.2 protocols are not supported by SDK and CLI releases before version 6.5. When vCenter Server 6.0 U3 and later has TLSv1.0 disabled, and uses TLSv1.1 and TLSv1.2 there is no supported communication protocol available for SDK and CLI.

Resolution

These SDKs are recommended for use with vCenter Server 6.0 U3:
These CLIs are recommended for use with vCenter Server 6.0 U3:

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: