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"No host data available" error in the Hardware Status tab after upgrading to vCenter Server 6.5 (2148520)

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Symptoms

  • After upgrading to vCenter Server 6.5, the vSphere Web Client displays this error when selecting the Hardware Status tab:

    No host data available

  • In the vpxd.log file, there are entries similar to:

    2016-12-21T20:34:13.439Z verbose vpxd[7F7629716700] [Originator@6876 sub=HTTP server] Sent NotFound response for GET /hwh/gwtcim?host=host-92&op=getHostData
    2016-12-21T20:34:31.903Z verbose vpxd[7F760BD7A700] [Originator@6876 sub=HTTP server] Sent NotFound response for GET /hwh/gwtcim?host=host-108&op=getHostData
    2016-12-21T20:34:49.191Z verbose vpxd[7F7629B1E700] [Originator@6876 sub=HTTP server] Sent NotFound response for GET /hwh/gwtcim?host=host-108&op=getHostData
    2016-12-21T20:35:05.711Z verbose vpxd[7F7628471700] [Originator@6876 sub=HTTP server] Sent NotFound response for GET /hwh/gwtcim?host=host-33&op=getHostData

    Note: The vpxd.log file is located at:
    • In vCenter Server 6.5 - %ALLUSERSPROFILE%\VMWare\vCenterServer\logs\vmware-vpx.
    • In vCenter Server Appliance 6.5 - /var/log/vmware/vmware-vpx.

  • In the vsphere_client_virgo.log file, there are entries similar to:

    [2016-12-21T20:35:05.714Z] [ERROR] data-service-pool-502  70000186 100011 200005 com.vmware.vise.util.http.ConnectionManager   Error reading from the stream: https://VC.com:443/hwh/gwtcim?host=host-33&op=getHostData
    [2016-12-21T20:35:05.714Z] [WARN ] data-service-pool-502   70000186 100011 200005 com.vmware.vim.cimmonitor.http.impl.CimVc61HttpService   No host data. Http status code: 404

    Note: The vsphere_client_virgo.log file is located at:

    • In vCenter Server 6.5 - %ALLUSERSPROFILE%\VMWare\vCenterServer\logs\vsphere-client\logs.
    • In vCenter Server Appliance 6.5 - /var/log/vmware/vsphere-client/logs.

Note: These log excerpts are an example. Date, time, and environmental variables may vary depending on your environment.

Purpose

To work around the No host data available error, remove the stale serviceID.

Cause

This issue occurs due to an issue with the component manager registration when upgrading from vSphere 5.5 or 6.0 to vSphere 6.5.

Resolution

This is a known issue affecting the vCenter Server 6.5.

Currently, there is no resolution.

To work around this issue, remove the stale serviceID:
  1. From a Web browser, connect to the vCenter Server Managed Object Browser (MOB) at:

    https://vcenter_FQDN.com/cm/mob

  2. Login as the administrator@vsphere.local user.
  3. Click Search.
  4. Edit the Value column to only have these lines:

    <searchCriteria></searchCriteria>

  5. Click Invoke Method.
  6. Press Ctrl+F and search for cis.vws.servicename.
  7. Copy the serviceID string directly above cis.vws.servicename.


  8. Exit this window.
  9. Click UnregisterService.
  10. Under the Value column, enter the string copied in step 7.
  11. Click Invoke Method.

Additional Information

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See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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