Search the VMware Knowledge Base (KB)
View by Article ID

Upgrading to NSX for vSphere 6.3.0 fails when using Hardware Gateway (2148511)

  • 1 Ratings
Language Editions

Symptoms

When upgrading to VMware NSX for vSphere 6.3.0 with a HW VTEP in the environment, you may experience this symptom:
  • Upgrade is halted
  • You see the error similar to:

    Cannot continue upgrade due to errors: "(1)" Hardware Gateway(s)found in the system. Unable to proceed with the upgrade. Please contact VMWare Support to continue. Please correct before proceeding.

Cause

This issue occurs because there is a HW VTEP configuration present. NSX for vSphere 6.3.0 supports only TLS 1.2 secure connections in the control plane. HW VTEPs that do not support TLS, thus cannot connect to the NSX Controllers. The upgrade has been blocked to avoid disconnecting these HW VTEPs and impacting network traffic.

Resolution

To resolve this issue, contact VMware Support. To contact VMware support, see Filing a Support Request in My VMware (2006985) or How to Submit a Support Request. VMware can assist on verifying your Hardware Gateway is TLS 1.2 compliant which allows the upgrade to move forward.

Partner Support for TLS 1.2

PARTNER TLS 1.2 SUPPORT
SWITCH O/S VERSION
Arista
YES
EOS 4.17.3
Brocade YES Requires patch NOS 7.0.1b
Dell - DNOS
NO
Available mid 2017
Dell - Cumulus
NO
TBD
HPE NO
TBD
Huawei
YES
CloudEngine V200R002
Juniper YES
14.1X53-D40

See Also

Language Editions

ja,2149430;zh_cn,2149528

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 1 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 1 Ratings
Actions
KB: