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vSAN host may encounter a purple diagnostic screen during performance statistics updates (2148420)

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Symptoms

  • The ESXi 6.0 vSAN host fails with a purple diagnostic screen.
  • The purple diagnostic screen contains entries similar to:

    YYYY-MM-DDT22:59:29.686Z cpu40:84493)0x43939069b4c8[0x41803cd4f30c]DOMClient_IsTopObject@com.vmware.vsan#0.0.0.1+0x18 stack: 0x43930000
    YYYY-MM-DDT22:59:29.687Z cpu40:84493)0x43939069b4d0[0x41803cdfdcd9]DOMListUuidTopHierarchyCbk@com.vmware.vsan#0.0.0.1+0x69 stack: 0x900
    YYYY-MM-DDT22:59:29.687Z cpu40:84493)0x43939069b5900x41803c94d83f]VSANUUIDTable_Iterate@com.vmware.vsanutil#0.0.0.1+0x4b stack: 0x139d
    YYYY-MM-DDT22:59:29.687Z cpu40:84493)0x43939069b5d0:[0x41803cdfe6f2]DOMVsi_ListTopClients@com.vmware.vsan#0.0.0.1+0x5a stack: 0x66
    YYYY-MM-DDT22:59:29.688Z cpu40:84493)0x43939069b5f0[0x41803bd5aab4]VSI_GetListInfo@vmkernel#nover+0x354 stack: 0x41803cdfe698
    YYYY-MM-DDT22:59:29.688Z cpu40:84493)0x43939069b670[0x41803c0017ae]UWVMKSyscallUnpackVSI_GetList@<None><None>+0x216 stack: 0x439300000
    YYYY-MM-DDT22:59:29.688Z cpu40:84493)0x43939069bef0[0x41803bfc04f8]User_UWVMKSyscallHandler@<None>#<None>+0xb4 stack: 0x79156a8
    YYYY-MM-DDT22:59:29.689Z cpu40:84493)0x43939069bf20[0x41803ba8e4c1]User_UWVMKSyscallHandler@vmkernel#nover+0x1d stack: 0x0
    YYYY-MM-DDT22:59:29.689Z cpu40:84493)0x43939069bf30[0x41803bac7044]gate_entry_@vmkernel#nover+0x0 stack: 0x0
Note: The log excerpts are examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue is due to a condition that arises when the vSAN top object list is accessed. In certain scenarios, the list can be queried prior to an object being fully initialized. When this occurs, the host will panic.

Resolution

This issue is resolved in ESXi 6.0 Update 3, available at VMware Downloads and ESXi 6.5.0d(vSAN 6.6) available at VMware Downloads.

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