Search the VMware Knowledge Base (KB)
View by Article ID

vSAN PCIE/NVMe SSDs Receive Warning for HCL Health Check (2146676)

  • 3 Ratings

Symptoms

If you use PCIE/NVMe SSDs in the capacity layer of a vSAN cluster, the SSDs are issued a warning for the Hardware Compatibility - SCSI Controller on Virtual SAN HCL check in vSAN Health Service. Even though the devices are certified with the correct drivers and firmware versions, an alarm is triggered.

Purpose

This article explains the root cause for this issue, and provides information to help you work around the issue.

Cause

The Hardware Compatibility - SCSI Controller on Virtual SAN HCL health check scans the I/O controllers on storage devices in the vSAN cluster, but it cannot scan PCIE/NVMe SSDs because they do not use standard I/O controllers. These devices use software to provide the function of I/O controllers. Because no I/O controller exists, vSAN Health Service reports that the devices are not compatible.

Resolution

This issue is resolved in vSAN 6.5 GA, available at VMware Downloads.

To work around the issue, disable the alarm for this health check:
  1. Navigate to the vCenter Server object in the vSphere Web Client, and click Manage  > Alarm Definitions.
  2. Edit this alarm: Virtual SAN Health Alarm SCSI Controller on Virtual SAN HCL.

    Note: These alarms may also be triggered and may be disabled if desired:

    • Virtual SAN Health Alarm Controller Driver
    • Virtual SAN Health Alarm Virtual SAN HCL Health
    • Virtual SAN Health Alarm Controller Release Support

  3. Deselect the Enable the alarm check box.

See Also

Update History

11/15/2016 - Added the details of the vSAN 6.5 release, that fixes this issue.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 3 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 3 Ratings
Actions
KB: