Search the VMware Knowledge Base (KB)
View by Article ID

IaaS Management Agent does not start in vRA 7.1 (2146550)

  • 0 Ratings

Symptoms

After upgrading from vRealize Automation 6.2.3 or earlier versions to 7.1, you experience these symptoms:

  • The IaaS Management Agent services cannot start.
  • This issue only occurs on vRealize Automation versions prior to 6.2.4.
  • In the Management Agent logs, you see entries similar to:

    System.Configuration.ConfigurationErrorsException: Required attribute 'id' not found.

Cause

This issue occurs when the Management Agent ID is lost during upgrade.

Resolution

This issue is resolved in vRealize Automation 7.2, available at VMware Downloads.

To work around this issue if you do not want to upgrade:


  1. Log in to the vRealize Automation appliance through SSH.
  2. Run the command:

    vra-command list-nodes

  3. Locate the ID for the appropriate IaaS Management Agent node and copy it.
  4. Open the affected IaaS Management Agent config file.

    Note: The file usually located at C:\Program Files (x86)\VMware\vCAC\Management Agent\VMware.IaaS.Management.Agent.exe.config.

  5. Copy the ID into the <agentConfiguration> section.  

    For Example: <agentConfiguration id="9f74b84e-54c4-4d4c-b9ae-c4b9264f7262" pollingInterval="00:03:00">

  6. Restart the Management Agent and confirm that it is communicating without error.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: