Search the VMware Knowledge Base (KB)
Products:
View by Article ID

Incremental virtual machine backups effectively run as full backups when you enable consistent application quiescing (2145895)

  • 5 Ratings
Language Editions

Symptoms

When running Windows 2008 (and later) after upgrading the host to ESXi 6.0 Build 3825889 (EP6), you experience these symptoms:
  • When application consistent quiescing is enabled, Incremental virtual machine backups effectively run as a full backup.
  • The CBT API call QueryDiskChangedAreas() returns all sectors, which results in a full backup.
  • In the vmware.log file, for the individual virtual disk attached to the virtual machine, you see entries similar to:

    SNAPSHOT:SnapshotBranchDisk: Failed to acquire current epoch for disk /vmfs/volumes/vmfs_uuid/vm_folder/vm_name.vmdk : Change tracking is not active for this disk 572

Cause

When backup applications do incremental backups, they query the changed blocks from the last backup using the API call QueryDiskChangedAreas(). This entails opening the change block tracking file of the parent vmdk to query the change tracking information. When you use virtual machines with guest operating system Windows 2008 or later, the open task required to query the change block tracking file fails. 

This leads to the API providing all the blocks that have been written during the entire life of the virtual disk (.vmdk). So incremental backups, like full backups, end up taking a backup of the entire size of the virtual disk.

Note: No data is lost or corrupted. Due to this issue, incremental backups are effectively full backups.

Resolution

This is a known issue affecting VMware ESXi 6.0 EP6 only. Prior releases of ESXi 6.0 are not affected.

This issue is resolved in ESXi 6.0 Patch 03. For more information, see VMware ESXi 6.0, Patch ESXi-6.0.0-20160804001-standard (2145667).

If you do not want to upgrade at this time, review the workaround options below. If you are using a backup product, VMware recommends that you contact your backup vendor for any specific guidance on handling this issue.

You can work around this issue using either of these options:
  • Disable application-consistent quiescing on the affected virtual machines. For more information, see Enabling and disabling Windows 2008 and later application-consistent quiescing on ESXi/ESX (1028881).

    Notes:
    • After disabling application-consistent quiescing, quiesced snapshots revert to using file-system consistent quiescing.
    • After you disable application-consistent quiescing on the affected virtual machines, VMware recommends to perform a full backup again before performing incremental backup after applying this workaround. The incremental backups should now work as normal.

See Also

Update History

08/26/2016 - Removed specific VSAN considerations as the issue is resolved in the ESXi patch.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 5 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 5 Ratings
Actions
KB: