Search the VMware Knowledge Base (KB)
View by Article ID

Executing VMware vSphere SDK for Perl 6.0 Update 2 sample in RHEL 7.x fails with the error: SOAP request error - possibly a protocol issue (2145698)

  • 0 Ratings

Symptoms

When you are using vSphere SDK for Perl 6.0 Update 2 with RHEL 7.x, you experience these symptoms:

  • Executing VMware vSphere SDK for Perl 6.0 Update 2 fails
  • When you run the connect.pl script, it hangs for 3 minutes and stops with the XML

Cause

This issue occurs because yum install libwww-perl-5.837 IO-Compress-2.061 for RHEL 7.x installs default library for executing SDK samples.

Note: For RHEL 7.x, default perl-libwww 6.05 is installed. 

Resolution

This is a known issue affecting vSphere SDK for Perl 6.0 Update 2.
 
Currently, there is no resolution.
 
To work around this issue:
  • Open the /usr/share/perl5/VMware/VICommon.pm file using a text editor.
  • Add these entries:

    use LWP::Protocol::https10 ();
    LWP::Protocol::implementor('https', 'LWP::Protocol::https10');

  • Save and close the file.
 

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: