Search the VMware Knowledge Base (KB)
View by Article ID

vCenter Server 6.0 Update 2 displays on non-vSAN enabled ESXi hosts displays the message: Retrieve a ticket to register the vSAN VASA Provider (2145308)

  • 62 Ratings
Language Editions

Symptoms

  • This message is displayed for non-vSAN enabled ESXi hosts:
    Retrieve a ticket to register the Virtual SAN VASA Provider
  • The environment uses vCenter Server 6.0 Update 2 and does not have vSAN enabled

Cause

This issue occurs due to the vSAN health service attempting to register VASA providers from the ESXi hosts.

Resolution

This issue is resolved in vCenter Server 6.0 Update 3, available at VMware Downloads.

In some cases this issue can cause issues with deploying new PSC's in the same SSO domain and repointing vCenter Servers across PSC sites. For more information, see Platform Services Controller 6.0 deployment takes several hours (2147428).

If vSAN is not in use in the infrastructure managed by the vCenter Server, the vSAN Health Service can be disabled.

To stop and disable the vSAN Health Service on vCenter Server for Windows

  1. Open the Services MSC
  2. Locate and "VMware Virtual SAN Health Service" service and click Stop.

  3. Double-click the VMware Virtual SAN Health Service to open its dialogue box.
  4. On the General tab, change the Startup type to Disabled and click OK

To stop and disable the vSAN Health Service on the vCenter Server Appliance

  1. Log in to the vCenter Server Appliance via SSH and activate a Bash shell. For more information on logging in to the vCenter Server appliance, see the Using the Appliance Shell to Configure the vCenter Server Appliance section in the vCenter Server Appliance Configuration guide.

  2. Stop the vSAN Health Service:
    # service vmware-vsan-health stop
    Stopping Virtual SAN Health Service:


  3. Disable the vSAN Health Service:
    # chkconfig vmware-vsan-health off

Impact/Risks

Disabling the vSAN Health Service has no impact if vSAN is not in use in the environment managed by the associated vCenter Server instance. If vSAN is enabled, the vSAN Health Service and associated alert and monitoring functions in the Web Client will not be available.
Disabling the vSAN Health Service is not recommended if one or more vSAN clusters are managed by the vCenter Server.

Tags

vsan, vasa

See Also

Update History

02/23/2017 - Updated with vCenter Server 6.0 U3 fix details.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 62 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 62 Ratings
Actions
KB: