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Custom vSphere tags are not displayed in VMware vRealize Operations Manager 6.x (2144602)

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Symptoms

  • Custom tags set in vCenter Server fails to appear in VMware vRealize Operations Manager.
  • Custom groups with criteria based on custom tag fails to update.

Cause

The issue occurs when the collection user of vCenter Adapter does not have permissions to discover custom tags.

Resolution

To resolve this issue, grant the permission to the collection user to collect vCenter Server metrics and discover custom tags.

Note: The collection user account may also need to be assigned Global Read only permissions.You can assign global read only permissions, by logging into web-client as administrator@vsphere.local.

To grant permissions to the collection user:
  1. Log in to the vSphere Client UI as an Administrator.
  2. Navigate to Home > Roles.
  3. Select the role given to the collection user, specified in VMware vRealize Operations Manager.
  4. Edit the role, and grant these permissions:

    Global > Health
    Profile-driven storage
    Storage views > View
    vCenter Inventory Service
  5. Click OK to save the changes.
Notes:
  • The custom tags appears in VMware vRealize Operations Manager after few collection cycles.
  • In vRealize Operations Manager 6, restart the collection service for custom tags to appear. This is best accomplished by taking the cluster Offline in the admin UI, then bringing it back Online.


To verify the collection user specified in vRealize Operations Manager:
  1. Log in to the vRealize Operations Manager Product UI as the admin user.
  2. Navigate to Administration > Solutions.
  3. Select the VMware vSphere solution and click Configure.
  4. Select the vCenter adapter and click Edit next to Credential.

    Note: The Collection user is displayed in the User Name field.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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