Search the VMware Knowledge Base (KB)
View by Article ID

Connecting to View desktops with Horizon View agent 6.0.x or 6.1.x hosted on ESXi 5.5 Update 3b or later fails with a black screen (2144518)

  • 3 Ratings

Symptoms

When upgrading to ESXi 5.5 Update 3b or later with Horizon View Agents 6.0.x or 6.1.x, you experience these symptoms:
  • Connecting to the View desktop fails with a black screen
  • The bundled VMware Tools are upgraded to VMTools 10.0.0 or later for View desktops
  • In the View agent PCOIP logs, located at DriveLetter:\ProgramData\VMware\VDM\logs\, you see entries similar to:

    LVL:0 RC:0 IMG_FRONTEND :Calling open display in Tera2 mode.
    LVL:0 RC:0 IMG_FRONTEND :configure_displays: 1 display(s) initially reported!
    LVL:2 RC:0 IMG_FRONTEND :configure_displays: (1) single display[0]: pos:(0, 0) w: 1024, h: 768, bpp: 32
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--* id: 48 mon_id: 0 pos: (0,0) w: 1024 h: 768
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--bpp: 32 --pitch: 4096 --map size: 1552 –fb size: 3145728
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--rot: 0 --pre-rot pitch: 4096 --frontend motion is enabled
    LVL:0 RC:0 EXTERN :svga_devtap ==> second render failed: 0xc0000008
    LVL:0 RC:0 EXTERN :svga_devtap ==> Error: screen dma failed
    LVL:0 RC:0 IMG_FRONTEND :flip_frame_buffer: General flip error [1 results for 1 displays]: [4001,0]
    LVL:0 RC:-500 IMG_FRONTEND :open_displays(): Flip error in open display first flip.


    Note
    :The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs because Horizon View Agents 6.0.2, 6.0.1. 6.0, 6.1.1 and 6.1 are incompatible with VMTools that are bundled with ESXi 5.5 Update 3b or later versions.

Resolution

To resolve this issue, upgrade to VMware Horizon 6.2.x.

Note: VMware recommends to upgrade VMware Horizon along with ESXi.

Alternatively, when you do not want to upgrade to VMware Horizon 6.2.x, use one of these options:
  • Do not upgrade the ESXi host to ESXi 5.5 Update 3b. If you have already upgraded to ESXi 5.5 Update 3b, you must downgrade and manually revert to the appropriate VMTools versions.
  • Disable auto upgrade options for VMTools. For more information on compatible combinations of Horizon View Agent versions and the downloadable VMTools versions, see the VMware Product Interoperability Matrixes.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 3 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 3 Ratings
Actions
KB: