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Connecting to View desktops with Horizon View Agent 6.1.x hosted on ESXi 6.0 Update 1 or later fails with a black screen (2144453)

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Symptoms

When upgrading to ESXi 6.0 Update 1 or later with Horizon View Agent 6.1.x, you experience these symptoms:

  • Connecting to the View desktop fails with a black screen
  • The bundled VMware Tools are upgraded to VMTools 10.0.0 or later for View desktops
  • In the View agent PCOIP logs, located at DriveLetter:\ProgramData\VMware\VDM\logs, you see entries similar to:

    LVL:0 RC:0 IMG_FRONTEND :Calling open display in Tera2 mode.
    LVL:0 RC:0 IMG_FRONTEND :configure_displays: 1 display(s) initially reported!
    LVL:2 RC:0 IMG_FRONTEND :configure_displays: (1) single display[0]: pos:(0, 0) w: 1024, h: 768, bpp:  32
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--*  id: 48  mon_id: 0 pos: (0,0)  w: 1024   h: 768
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--bpp: 32 --pitch: 4096 --map size: 1552 –fb size:  3145728
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--rot: 0  --pre-rot pitch: 4096 --frontend motion is  enabled
    LVL:0 RC:0 EXTERN :svga_devtap ==> second render failed: 0xc0000008
    LVL:0 RC:0 EXTERN :svga_devtap ==> Error: screen dma failed
    LVL:0 RC:0 IMG_FRONTEND :flip_frame_buffer: General flip error [1 results for 1 displays]: [4001,0]
    LVL:0 RC:-500 IMG_FRONTEND :open_displays(): Flip error in open display first flip.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs because Horizon View 6.1.x agents are incompatible with VMTools that are bundled with ESXi 6.0 Update 1 or later versions.

Resolution

To resolve this issue, upgrade to VMware Horizon 6.2.x or later.

Note
: VMware recommends upgrading VMware Horizon along with ESXi.

Alternatively, when you do not want to upgrade to VMware Horizon 6.2.x, use one of these options:
  • Do not upgrade the ESXi host to ESXi 6.0 Update 1. If you have already upgraded to ESXi 6.0 Update 1, you must downgrade and manually revert to the appropriate VMTools versions.
  • Disable auto upgrade options for VMTools. For more information on compatible combinations of Horizon View Agent versions and the downloadable VMTools versions, see the VMware Product Interoperability Matrixes.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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