Search the VMware Knowledge Base (KB)
View by Article ID

Pre-upgrade check failure during vCenter Server 5.5.x upgrade (2144262)

  • 2 Ratings

Details

Upgrading vCenter Server from 5.5 Update 3 to 6.0 Update 2 fails during the pre-upgrade check.
The failure is seen when you use SQL 2012 or 2014 AAG setup.

Solution

Perform the following steps to configure the database to meet the vCenter Server upgrade requirements on Windows:

  1. On the vCenter Server machine, update the ODBC Data source Name (DSN) with Standalone Database IP address.
    Note: The ODBC DSN points to the listener IP address.
  2. On the primary node database machine, remove the database details from AAG configuration.
  3. Upgrade the vCenter Server to 6.0 Update 2.
  4. On the primary node database machine, take a back up of the database.
  5. To avoid conflict, delete the database with the same name from the secondary node.
  6. Add the database to the AAG configuration.

Additional Information

For translated versions of this article, see:

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 2 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 2 Ratings
Actions
KB: