Search the VMware Knowledge Base (KB)
View by Article ID

After removing and re-inserting a disk associated with vSAN, the disk is not re-added to the vSAN disk group (2143296)

  • 0 Ratings
Language Editions

Symptoms

When running vSAN (formerly known as Virtual SAN) 6.x, you experience these symptoms:
  • If a physical disk used for vSAN is removed from a vSAN host and then re-inserted, the disk may not rejoin its associated vSAN disk group.
    When this occurs, no error is associated with the disk group, but the Virtual SAN Health Status is reported as null in the vSphere Web Client Disk Management view:



  • When examining the vSAN disks using the esxcli command set, the disk status is reported as In CMMDS: false.

    Example output:

    # esxcli vsan storage list
    mpx.vmhba2:C0:T2:L0
       Device: mpx.vmhba2:C0:T2:L0
       Display Name: mpx.vmhba2:C0:T2:L0
       Is SSD: false
       VSAN UUID: 527aa9f8-33fb-ccb0-ad85-8a698af8fa1a
       VSAN Disk Group UUID: 528abaa2-d195-40f1-2c1e-06ff240d6cb4
       VSAN Disk Group Name: mpx.vmhba2:C0:T0:L0
       Used by this host: true
       In CMMDS: false
       Checksum: 7271539155897821021
       Checksum OK: true
       Emulated DIX/DIF Enabled: false

Cause

When a disk used in a vSAN disk group is removed, open handles to the device are closed and device is unregistered from the ESXi SCSI subsystem. When the disk is reinserted, the ESXi SCSI subsystem re-enumerates the device and makes it available, but vSAN does not automatically reclaim the disk.

Resolution

This issue is resolved in VMware ESXi 6.0, Patch Release ESXi600-201608001. For more information, see VMware ESXi 6.0, Patch Release ESXi600-201608001 (2145663).

To work around this issue if you do not want to upgrade:
  1. Re-insert the vSAN disk.
  2. Refresh the host storage system in the vSphere Web Client. 
  3. The vSAN host reclaims the device.

Additional Information

To be alerted when this article is updated, click Subscribe to Document in the Actions box.

See Also

Update History

08/04/2016 - Issue fixed in VMware ESXi 6.0, Patch Release ESXi600-201608001. Updated details.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: