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"Host cannot communicate with all other nodes in vSAN enabled cluster" error (2143214)

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Symptoms

When a host in the vSAN cluster running on vSphere 6.0 Update 1b is down for maintenance, the ESXi hosts in the cluster report the error:

Host cannot communicate with all other nodes in virtual SAN enabled cluster

After the node(s) reboots and rejoins the cluster, the message does not clear automatically. This message appears in the Summary tab in the vSphere Web Client and the ESXi host shows a notification triangle, though no alarms are triggered.

Note: For additional symptoms and log entries, see the Additional Information section.

Purpose

Host cannot communicate with all other nodes in virtual SAN enabled cluster error in the ESXi host is resolved in ESXi 6.0 Update 2.

Cause

This message occurs on all hosts in a vSAN cluster while one or more nodes are down for maintenance and therefore are not communicating with the rest of cluster, or when there is a legitimate problem with vSAN cluster communications. Under normal circumstances, this message is automatically cleared after the hosts have resumed communication. If this message appears in the Summary tab while all other indicators report that the vSAN network is healthy, this issue may be cosmetic.

Resolution

This cosmetic issue is resolved in VMware ESXi 6.0 Update 2, available at VMware Downloads.

To work around this issue if you do not want to upgrade,  use one of these options:
  • Restart the VPXA management agent on vSAN nodes. This refreshes the information in vCenter Server and clears the message.

    Note: Restarting the vCenter management agent on the ESXi host can cause a brief interruption to host manageability. In extreme cases, the host may momentarily enter a not responding state in vCenter Server or pending operations fail and must be retried.

    To restart the VPXA (vCenter Server) management agent on the vSAN cluster ESXi host nodes:
    1. Enable SSH or the ESXi Shell on each host in the vSAN cluster.
    2. Log in to the host in the vSAN cluster using SSH or the ESXi Shell.
    3. Restart the VPXA management agent by running this command

      # /etc/init.d/vpxa restart

      Note: Wait approximately one minute before proceeding to the next host. This allow information from each host to update in vCenter Server one-at-a-time.


  • Remove the host from the vSAN cluster and re-add. This forces all hosts to update the information about the cluster membership and clears the message.

    Note: When attempting to remove and re-add the host, data synchronization does not occur when the host is in maintenance mode and out of the vSAN cluster. If you select the Ensure accessibility maintenance mode option, some objects may be unprotected while executing the workaround.

    To remove a host from the vSAN cluster and re-add:
    1. Select the ESXi host in the vSAN cluster that can be put to the maintenance mode temporarily

      Note: VMware recommends to select the least busy/utilized host.

    2. In the vSphere Web Client, right-click the ESXi host and click Enter Maintenance Mode.

      Notes:
      • Select either the Ensure Accessibility or Full data migration options for vSAN maintenance mode.
      • If applicable, allow powered-off virtual machines to be migrated to the remaining ESXi hosts.

    3. Remove the host from the vSAN cluster
      1. Select the host.
      2. Drag the host out of the cluster.
      3. Place the host in the datacenter object in the vCenter Server inventory. 

        Note: After moving the host into the data center, wait for approximately two minutes.

    4. Drag the host back into the vSAN cluster.
    5. After adding the host back in the vSAN cluster, right-click the host and click Exit Maintenance Mode.

      Note: The message on the remaining hosts should be clear.

Note: These workarounds successfully clear the message. However, you may have to apply the workaround again if the message reappears. This message may reappear in events, such as network problem, host failure/reboot, or host maintenance. If you need further assistance, open a Support Request with VMware Support.

Additional Information

You experience these additional symptoms:

  • The vSAN Disk Management view in the vSphere Web Client does not show any network partitions.
  • vSAN Health Service does not report any network-related problems.
  • The Issues tab for the host(s) in the vSphere Web Client displays an error that shows a time stamp that is more than five minutes old.

Tags

host cannot communicate, communication error, vSAN enabled cluster

See Also

Update History

03/15/2016 - Added the details of the ESXi 6.0 Update 2 release, which resolves this issue.

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