Search the VMware Knowledge Base (KB)
View by Article ID

Disabling TLSv1 Support in vRealize Infrastructure Navigator (2139941)

  • 0 Ratings

Details

In vRealize Infrastructure Navigator, TLSv1.0 is supported for communications between the vSphere Web Client extension and the vRealize Infrastructure Navigator appliance for users of vCenter Server 5.1. Users of vCenter Server 5.5 or vCenter Server 6.0 can disable this support. 

Warning
: If you have vCenter Server 5.1 installed, and you disable this protocol, vRealize Infrastructure Navigator will no longer work.

Solution

To disable the TLSv1 protocol:

  1. Log on to vRealize Infrastructure Navigator appliance through SSH or console.
  2. Run /opt/vadm-engine/bin/disable_security.
  3. Using JConsole, connect to vRealize_Infrastructure_Navigator_IP_address:6970

    Note:Replace vRealize Infrastructure Navigator IP address with the actual IP. You do not need to enter a user name or password to connect.

  4. On the JConsole, navigate to MBeans.
  5. Under com.vmware.vadm > SystemControl > Operations, click disableTlsv1.

  6. Run /opt/vadm-engine/bin/enable_security.
  7. Run this command to restart the vRealize Infrastructure Navigator appliance:

    monit restart vcdm-engine
Note: You can also use this procedure to enable the TLSv1 protocol, by clicking enableTlsv1.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: