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Historical data is lost in VMware vRealize Operations Manager 6.1 (2137020)

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Symptoms

  • Historical data is lost due to data purge in VMware vRealize Operations Manager 6.1
  • In the Product UI, you see the alert:

    Corrupted fsdb files found.

  • In the /data/log/vcops/log/datapurging-X.log file, you see entries similar to:

    2015-10-12 14:06:10,507 INFO [Activity Executor __DEFAULT_ACTIVITY_EXECUTOR - 5] com.integrien.alive.controller.persistence.ResourceDeletion.DataPurging.submitPurgeJobs - successfully deleted resource:170580 from shard:vRealize Ops Shard-430a57ed-c6a7-4046-b6e5-3b071ca166b4

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Cause

This issue occurs when more then 90%  of disk space is used.

Resolution

This is an expected behavior in VMware vRealize Operations Manager 6.x.

By default, the system starts purging older data when the /storage/db disk space is below 10%.

To work around this issue, alter the threshold value:

To change the threshold value:
  1. Log in to the master node.
  2. Open the $ALIVE_BASE/user/conf/fsdb/fsdb.properties file using a text editor.
  3. Locate this entry:
    minFSDBDriveFreeSpacePercentage = Value
    Set the minFSDBDriveFreeSpacePercentage parameter to a value less than 10
  4. Save and close the file.
  5. Repeat steps 1 to 4 on all other nodes in the cluster.
  6. Log in to the Admin UI.
  7. Click Take Offline.
     Enter a description in the Reason field.
  8. Click OK.
  9. After all nodes and the cluster are offline, click Bring Online to bring the cluster back online.

Impact/Risks

changing the threshold may result in filing the disk space up to 100%, resulting in the node(s) to crash.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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