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The vCenter Server 6.0 Summary tab displays the message: Performance statistics rollup from Past Week to Past Month is not occurring in the database (2135488)

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Symptoms

  • When connected to vCenter Server with the vSphere Client or the vSphere Web Client, you see this message on the Summary tab:

    Performance statistics rollup from Past Week to Past Month is not occurring in the database

  • In the %ALLUSERSPROFILE%\VMware\vCenterServer\logs\vmware-vpx\vpxd.log file, you see entries similar to:

    2015-09-24T04:13:32.114+09:00 verbose vpxd[04264] [Originator@6876 sub=alarmMo opID=ProcessScaHealthStatusPolling-6bb69ee1] [ScaHealthPollManager::PostHealthEvent] Posted Event with componentId = vpxd, serviceId = vpxd, green -> yellow
    2015-09-24T05:59:56.041+09:00 verbose vpxd[04264] [Originator@6876 sub=alarmMo opID=ProcessScaHealthStatusPolling-6bb69ee1] [ScaHealthPollManager::PostHealthEvent] Posted Event with componentId = vpxd, serviceId = vpxd, yellow -> green

  • vCenter Server health status changes between green and yellow.
  • Running the stats_rollup2_proc and stats_rollup3_proc on the vCenter Server SQL database fails.

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs because the vCenter Server SQL database is missing the VPX_STAT_COUNTER_M1 index in vCenter Server 6.0.  

Resolution

This is a known issue affecting vCenter Server 6.0.

To resolve this issue, create the VPX_STAT_COUNTER_M1 index using the user account, as vpxuser, of vCenter Server database:
  1. Open the SQL Management Studio and connect to the vCenter Server database using the vCenter Server user to connect.
  2. Create a backup of the vCenter Server database.
  3. Select New Query and execute this query:

    use vCenter_Server_Database
    CREATE INDEX VPX_STAT_COUNTER_M1 ON VPX_STAT_COUNTER(STAT_ID,COUNTER_ID)


    For example:

    use vcdb
    CREATE INDEX VPX_STAT_COUNTER_M1 ON VPX_STAT_COUNTER(STAT_ID,COUNTER_ID)


  4. To check for data that needs to be processed, execute this query:

    select COUNT(*) from vpx_sample_time2 where rollup_counter is null
    and DATEDIFF(HH, sample_time,getutcdate()) > 6
    go


  5. If the query does not return 0, run these steps:
    1. Navigate to Server > SQL Server Agent.

      Note
      : Ensure that the SQL Server Agent is running. If it is not running, right-click the SQL Server Agent and select Start.

    2. Click Jobs.
    3. Right-click Past Week stats rollup vCenter_Server_Database.
    4. Click Start Job at Step.
    5. Click Start.
    6. After the job completes, click Close.
    7. Repeat the query in Step 4.
    8. If the query does not return 0. Run steps a through h until it returns 0. If the job is running successfully in some time, it takes multiple runs to clear the data that is not processed.

Additional Information

This issue does not occur when the vCenter Server 6.x database is installed on Oracle or vPostgres. 

vCenter Server 5.x is unaffected.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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