Search the VMware Knowledge Base (KB)
View by Article ID

Creating or upgrading the NSX 6.x Edges fails after adding an IPv6 address under NSX Management interface (2127561)

  • 0 Ratings
Language Editions

Symptoms

After adding an IPv6 address under NSX Management interface, you experience these symptoms:
  • Creating or upgrading an Edge fails on VMware NSX for vSphere 6.x
  • In the /home/secureall/secureall/logs/vsm.log file of the NSX Manager, you see entries similar to:

    2015-07-24 15:27:06.636 MDT ERROR TaskFrameworkExecutor-6 AbstractEdgeApplianceManager:185 - Timed out waiting for Edge vm {}. Vm took too long to boot and respond
    2015-07-24 15:51:50.513 MDT ERROR TaskFrameworkExecutor-8 AbstractEdgeApplianceManager:185 - Timed out waiting for Edge vm {}. Vm took too long to boot and respond
  • In the /var/log/vsfwd.log file on the ESXi host, you see errors similar to:

    2015-07-24T21:18:40Z vsfwd: [ERROR] Unable to Write to Socket 18 Err No 32 Return Value -1
    2015-07-24T21:18:40Z vsfwd: [ERROR] recv error: 110
    2015-07-24T21:18:45Z vsfwd: [INFO] Connected to 8D6AD363:1025.
    2015-07-24T21:18:45Z vsfwd: [ERROR] Queuing as Unable to Write 305 Bytes for VMCI Client For Client Type VMCI error ret -1 errno 107?

     
    Note: The preceding errors are signs of connection timed out issues between the vsfwd service and NSX Manager.
  • Running the tcpdump -uw command on the ESXi host management interface reports an output similar to:

    listening on vmk0, link-type EN10MB (Ethernet), capture size 96 bytes
    20:50:20.529347 IP 10.33.83.7.45170 > 255.255.255.255.5671: Flags [S], seq 2058971879, win 65535, options [mss 1460,sackOK,eol], length 0
    tcpdump-uw: pcap_loop: recvfrom: Interrupted system call
    1 packets captured


    This output indicates that the host is unable to resolve the Fully Qualified Domain Name (FQDN) and does not reach the NSX IP address.

  • For more information, see Capturing a network trace in ESXi using Tech Support Mode or ESXi Shell (1031186).

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs because both IPv4 and IPv6 address are defined under the NSX management interface. The NSX Manager switches to use its hostname for configuring the ESXi hosts from the Advance Config variables.

In this case, when ESXi hosts are prepared by the NSX Manager, the FQDN of the NSX Manager is pushed to the hosts from the Advanced Config variables. The FQDN does not get resolved by the proxy process for the Edge and therefore, Edges are unable to connect to the RabbitMQ Broker on the NSX Manager.

Resolution

This issue is resolved in VMware NSX for vSphere 6.3.0, available at VMware Downloads.

To work around this issue if you do not want to upgrade, remove the IPv6 address from the NSX management interface and manually change the FQDN to IPv4 address on the ESXi hosts.

To remove the IPv6 address from the NSX management interface:
  1. Log in as admin to the NSX Manager Command Line Interface (CLI) console.
  2. Run the config t command.
  3. Run the interface mgmt command.
  4. Run the no ipv6 IPv6_address command.
  5. Reboot the NSX Manager.

To manually change the FQDN to IPv4 address on the ESXi host:

  1. Log in as root to the ESXi host console through SSH.
  2. Run this command:
     
    esxcfg-advcfg -q -s IPv4_address /UserVars/RmqIpAddress
     
    Note: After applying the workaround, new ESXi hosts added in future, will have their FQDN configured if re-prepped. This can also apply to present ESXi hosts. You can resolve this manually by referencing this KB article. If possible, re-prep the ESXi hosts after removing the IPv6 address from the management interface to avoid updating the IPv4 address manually.

Additional Information

To be alerted when this article is updated, click Subscribe to Document in the Actions box.

See Also

Language Editions

ja,2137329

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: