Search the VMware Knowledge Base (KB)
View by Article ID

After upgrading to VMware ESXi 5.5 Patch Release ESXi550-201504002, virtual machines using VMware NSX for vSphere 6.x or Cisco Nexus 1000v are unable to communicate across hosts (2116370)

  • 12 Ratings

Symptoms

After upgrading to VMware ESXi 5.5 Patch Release ESXi550-201504002 (build number: 2702864) with VMware NSX for vSphere 6.x or Cisco Nexus 1000v, you experience these symptoms:
    • Virtual machines on VXLAN Wires are unable to communicate across hosts with their Edges or Distributed Routers.
  • In NSX
    • Checking the netcpad service status (/etc/init.d/netcpad status) reports that the agent is not running:

      netCP agent service Not Running
    • The /var/log/netcpa.log file is empty with no logging.
    • In the /var/log/syslog.log file, you see entries similar to:
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/net...
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2'
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2' exited after 0 seconds (quick failure 1) 127
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2'
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2' exited after 0 seconds (quick failure 2) 127
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2'
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2' exited after 0 seconds (quick failure 3) 127
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2'
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2' exited after 0 seconds (quick failure 4) 127
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2'
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2' exited after 0 seconds (quick failure 5) 127
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: Executing '/bin/netcpa ++group=host/vim/vmvisor/netcpa,securitydom=2'
...
<YYYY-MM-DD>T<Time>Z watchdog-netcpa: End '/bin/netcpa ++group=netcpa,securitydom=2', failure limit reached

  • In Cisco Nexus 1000v
    • Checking VEM module (vemdpa) reports that it cannot start.
    • The VEM module on the ESXi is running in Headless Mode.
    • Checking the VEM module status (via command show module vem missing) from the VSM module(s), reports that the VEM module as missing.
    • When running the command opt/cisco/<version>/nexus/vem-nexus_version/sbin/vemdpa, you see output similar to:

      symbol lookup error: /usr/lib/vmware/lib/libvdsPublic.so: undefined symbol: Str_Strcpy

Resolution

This issue is resolved in VMware ESXi 5.5 Patch Release ESXi550-201505002 (build number: 2718055). For more information, see VMware ESXi 5.5, Patch Release ESXi550-201505002 (2114245).

To work around this issue, perform a roll back operation to your affected ESXi 5.5 hosts to their previous build(s) using the alternate boot bank. 

To ensure that your ESXi host's alternate bootbank has a previous version present and roll back to that version:
  1. Connect to the affected ESXi 5.5 host with an SSH session. For more information, see Using ESXi Shell in ESXi 5.x and 6.0 (2004746).
  2. Run this command to find the version of the alternate bootbank:

    less /altbootbank/boot.cfg | grep build

  3. Ensure that the returned value is not 2702864

    For example:

    build=5.5.0-2.62.2638301

  4. After confirming that the alternate bootbank contains a different build, revert to the alternate bootbank version.  For more information, see Reverting to a previous version of ESXi (1033604).
  5. If the ESXi host's alternate boot bank contains the Patch Release ESXi550-201504002 build (2702864), you will need to re-install ESXi 5.5 on the host.
VMware recommends the users using NSX for vSphere or Cisco Nexus 1000v to not upgrade their existing ESXi 5.5 hosts to ESXi 5.5 Patch Release ESXi550-201504002 (build number: 2702864).

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 12 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 12 Ratings
Actions
KB: