Search the VMware Knowledge Base (KB)
View by Article ID

"The user associated with the DSN has insufficient privileges" when upgrading from vCenter Server 5.x to 6.x (2114754)

  • 25 Ratings
Language Editions

Symptoms

  • Upgrading the VMware vCenter Server from 5.x to 6.x fails while validating the database.
  • You see the error:

    Error : The user associated with the DSN has insufficient privileges.
    Resolution: Provide sufficient privileges for the user by granting the user the following permissions:
    * VIEW SERVER STATE
    * VIEW ANY DEFINITION

Purpose

Granting additional privileges to the vCenter Server database user resolves the issue.

Cause

This issue occurs because vCenter Server 6.x requires additional privileges to be assigned to the vCenter Server database user.

Resolution

To resolve the issue, grant additional privileges to the vCenter Server database user.
  1. From the server that is hosting the vCenter Server database, open the Microsoft SQL Management Studio.
  2. Click New Query.
  3. Run this query to grant the appropriate permissions to the user that the vCenter Server uses to connect to the database:

    use master
    go
    grant VIEW SERVER STATE to [vCenter_database_user]
    go
    GRANT VIEW ANY DEFINITION TO [vCenter_database_user]
    go
For more information, see the vSphere Installation and Setup Guide.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 25 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 25 Ratings
Actions
KB: