Search the VMware Knowledge Base (KB)
View by Article ID

升级 VMware ESXi 主机失败并显示错误: 无法在主机上运行升级脚本 (2096959)

  • 0 Ratings

Symptoms

免责声明: 本文为 Upgrading a VMware ESXi host fails with the error: Cannot run upgrade script on host (2007163) 的翻译版本。 尽管我们会不断努力为本文提供最佳翻译版本,但本地化的内容可能会过时。 有关最新内容,请参见英文版本。



  • VMware vCenter Update Manager 升级 ESXi 主机进行到 92% 时失败。
  • 无法使用 ISO 映像从 ESXi 5.0 升级到 ESXi 5.1/5.5。
  • 无法使用 ISO 映像从 ESXi 5.1 升级到 ESXi 5.5。
  • 无法使用 ISO 映像从 ESXi 5.x 升级到 ESXi 6.0。
  • 无法从 ESXi 4.0 Update 1 或 Update 2 升级到 ESXi 5.0。
  • 使用 Update Manager 从 ESXi 4.0 Update 1 或 Update 2 升级到 ESXi 5.0 失败。
  • 您会看到以下错误:

    无法在主机上运行升级脚本 (Cannot run upgrade script on host)

  • C:\Documents and Settings\All Users\Application Data\VMware\Update Manager C:\Users\All Users\VMware\VMware Update Manager\Logs\vmware-vum-server-log4cpp.log 文件中,您会看到类似以下内容的条目:

    Remediation failed due to non mode failure

  • /var/log/vua.log 文件中,您会看到类似以下内容的条目:

    OSError: [Errno 39] Directory not empty: /bootbank/state.XXXXXXX (where XXXXXXX is a number)

Cause

如果 /bootbank/state.XXXXXXXX 目录不为空,则会出现该问题。

Resolution

要解决该问题,确保 /bootbank/state.XXXXXXXX 目录为空。
 
要确保 /bootbank/state.XXXXXXXX 目录为空,请执行以下操作:
  1. 登录到 ESXi 管理控制台。
  2. 运行以下命令:

    cd /var/log

  3. 使用 grep 命令,在 vua.log 文件中找到 state.XXXXXXX 及其对应的目录(将 XXXXXXX 替换为错误中指出的数字)

    例如:

    grep state.31110473 vua.log

  4. 运行以下命令:

    cd /bootbank/
    ls -l


    注意: 前述命令在 /altbootbank 上可能也需要,因为该目录也可能包含 state.XXXXXXX

  5. 运行以下命令以将目录切换到 /var/log/vua.log 文件中指出的 state.XXXXXXX 目录:

    cd state.XXXXXXX

    例如:

    cd state.31110473

  6. 运行以下命令:

    ls -l

    您会看到类似以下内容的输出:

    -rwx------ 1 root root 18297 Jan 10 2011 local.tgz

  7. 记下 state.XXXXXXX 目录中文件的名称。 例如,local.tgz
  8. 运行以下命令将文件上移一个目录级别:

    mv * ../

  9. 在 vCenter Server 中,修复主机。

    1. 选择 ESXi 主机。
    2. 单击 Update Manager 选项卡。
    3. 单击修复

Additional Information

要在更新本文时收到提醒,请在“Actions”框中单击 Subscribe to Document

Tags

简体中文 Simplified Chinese

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: