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Logging in with the VMware View Client using the Log In as Current User Feature fails with the message: Unable to logon as current user (2093288)

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Symptoms

  • Logging in to a Connection Server using View Client with the Log In as Current User Feature fails.
  • Manually logging in to the Connection Server using a username and password succeeds and Single Sign-On to the View Desktop works.
  • The View Client and the View Connection Server are on different domains with a valid two-way trust.
  • In the View Client logs, you see entries similar to:

    DEBUG (0B48) [libcdk] Got response from [Connection Server URL]
    <value>Unable to logon as current user.</value>

    Note: For more information on the location of the View log files, see Location of VMware View log files (1027744).

Cause

This issue occurs because the client machine have to communicate with the Connection Server Active Directory servers and does not use cached credentials for authentication. 

Resolution

To resolve this issue:
  1. Ensure that the Client machine communicates with the Connection Server domain over Kerberos.
  2. Create a rule to allow IP port 88 through the network firewall.

Additional Information

For more information on Log in as Current User, see the Using the Log In as Current User Feature Available with Windows-Based Horizon Client section in the View Authentication Guide.

For more information on Active Directory ports, see the Microsoft Knowledge Base article 179442.
 
Note: The preceding link was correct as of August 6, 2015. If you find a link is broken, provide feedback and a VMware employee will update the link.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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