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Cannot start the snmpd service from VMware vCenter Server (2056832)

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Symptoms

  • The snmpd service fails to start from vCenter Server.
  • You see this error:

    Call "HostServiceSystem.Start" for object "serviceSystem-125" on vCenter Server "vCenter_server_fqdn" failed.

Cause

This issue occurs because of a corrupt snmp.xml file in the host.

Resolution

To resolve this issue, copy the content of the snmp.xml file from a working host to the problem host.

To copy the contents of the file to the problem host:
  1. Log in to a console or SSH session on your host. For more information, see Using Tech Support Mode in ESXi 4.1 and ESXi 5.x (1017910).
  2. Go to the directory /etc/vmware:

    cd /etc/vmware

  3. Run this command to back up the snmp.xml file.

    cp snmp.xml snmp.xml.bkup

  4. Copy and paste this content in the snmp.xml file:

    <?xml version="1.0" encoding="ISO-8859-1"?>
    <config>
    <snmpSettings>
    <enable>true</enable>
    <port>161</port>
    <syscontact></syscontact>
    <syslocation></syslocation>
    <EnvEventSource>indications</EnvEventSource>
    <communities>public</communities>
    <loglevel>info</loglevel>
    <authProtocol></authProtocol>
    <privProtocol></privProtocol>
    </snmpSettings>
    </config>

  5. Save and close the file.
  6. Start the snmpd service from vCenter Server using the Sphere Client.

Additional Information

To start the SNMP service using the vSphere Client:
  1. Click the host.
  2. Click the Configuration tab.
  3. Select Security Profile and then click the Services Properties tab.
  4. Click the SNMP service, and then click Options.
  5. Click Start.
  6. Click OK.
  7. Click OK.

See Also

Update History

09/05/2014 - Added ESXi 5.5 to Products

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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