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Unable to install Flash on Windows Server 2012 for use with VMware vSphere Web Client 5.x (2054049)

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Symptoms

  • Unable to install Adobe Flash on Windows Server 2012.
  • When using vSphere products dependent on Flash (for example, the vSphere Web Client).

Cause

This issue occurs because by default, Flash is pre-installed but not enabled on Windows Server 2012.

Resolution

To resolve this issue, enable the Desktop Experience feature allowing you to use Flash with vSphere products dependent on Flash.
 
To enable the Desktop Experience feature, add the feature using one of these options:
  • Microsoft Powershell
  • The Initial Configuration Tasks Wizard
  • The Server Manager

To add the Desktop Experience feature using Microsoft Powershell:

    1. Run these Microsoft PowerShell commands with an Administrator account:

      import-module ServerManager
      Add-WindowsFeature -name Desktop-Experience,qWave -IncludeAllSubFeature -IncludeManagementTools

    2. Reboot the Windows server.

To add Desktop Experience using the Initial Configuration Tasks Wizard: 

    1. In the Customize This Server section, click Add Features.
    2. Click Next until you see the Features section.
    3. Expand the User Interfaces and Infrastructure and select Desktop Experience.
    4. Click Next.
    5. Click Install and respond to the wizard prompts to complete the wizard.

To add Desktop Experience using the Server Manager:

    1. From the Taskbar or Start menu, open Server Manager.
    2. Click Add roles and features.
    3. Click Next until you see the Features section.
    4. Expand the User Interfaces and Infrastructure and select Desktop Experience.
    5. In the Features Summary section, click Add Features.
    6. Click Desktop Experience.
    7. Click Next.
    8. Click Install and respond to the wizard prompts to complete the wizard.

Additional Information

For more information on the Desktop Experience feature, see Desktop Experience Overview from Microsoft TechNet.
 
Note: The preceding link was correct as of August 28, 2013. If you find the link is broken, provide feedback and a VMware employee will update the link.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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