Search the VMware Knowledge Base (KB)
View by Article ID

Unable to use Hyper-V platform inside a Windows 8 virtual machine (2044876)

  • 38 Ratings

Symptoms

  • Unable to use Hyper-V platform inside a Windows 8 virtual machine
  • When trying to enable/install Hyper-V in a Windows 8 virtual machine, you see the error:

    Hyper-V cannot be installed: A hypervisor is already running

Cause

This issue occurs if an incorrect operating system is selected for the virtual machine OS type.

Resolution

To resolve this issue, change the guest OS type to Hyper-V.

Caution: Hyper-V functionality inside VMware Fusion is experimental and is unsupported.

To change the guest OS type to Hyper-V:
  1. Shut down the virtual machine.
  2. Click Virtual machine > Settings.
  3. Select General and change the guest OS type to Hyper-V (unsupported).
  4. Select Processors & Memory in the Settings.
  5. In the Advanced options of Processors & Memory, select Enable hypervisor applications in the virtual machine
  6. Reboot the virtual machine to enable Hyper-V.
Alternatively, you can edit the .vmx (virtual machine configuration) file of the Windows 8 virtual machine to override VMware Fusion's default virtual machine settings for running a hypervisor inside a virtual machine.

To edit the .vmx and override VMware Fusion settings:
  1. Shut down the Windows 8 virtual machine.
  2. Navigate to the location of your virtual machine bundle. For more information, see  Locating the virtual machine bundle in VMware Fusion (1007599).
  3. Right-click the virtual machine bundle and select Show Package Contents.
  4. Locate the file ending with .vmx.
  5. Right-click the file and select Open With > TextEdit.
  6. Add this entry to the last line of the file:

    h
    ypervisor.cpuid.v0 = "FALSE"

  7. Save and close the file, then start the virtual machine.

Impact/Risks

Hyper-V functionality inside VMware Fusion is experimental and is unsupported.

See Also

Update History

08/21/2014 - Updated for Fusion 7.x

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 38 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 38 Ratings
Actions
KB: