Search the VMware Knowledge Base (KB)
View by Article ID

Change to ICMP ping response behavior in ESXi 5.1 and ESXi 5.5 (2042189)

  • 26 Ratings

Symptoms

In ESXi 5.1 and ESXi 5.5, it is no longer possible to ping VMkernel interfaces other than the management VMkernel interface from client machines in other networks and VLANs.

Cause

This behavior is a consequence of changes introduced in ESXi 5.1 and maintained in ESXi 5.5. ICMP Echo replies are now only sent back on the same interface that the Echo Request was received on.

This behavior was introduced because it is desired by multi-pathing capable applications. For example, an iSCSI or NFS storage filer may use ICMP pings to determine whether a given VMkernel is reachable or not. For this functionality to work as designed, the host must respond to these echo requests on the same VMkernel interface that they are received on.

There is no change in behavior when pinging from a source within the same subnet as the VMkernel interface, only when the ICMP Echo Reply must be routed to get back to the source.

In previous versions of ESXi, pings originating from a different subnet would simply be replied to based on the host's routing table, normally through the default gateway defined for the management interface, vmk0.

Note: This behavior is applicable only to ICMPv4 traffic. All other forms of TCP/IP traffic are routed normally via the host's routing table.

Resolution

When performing network troubleshooting with ESXi 5.5 or ESXi 5.1, ping VMkernel interfaces from a source machine in the same subnet.

For example, ping an ESXi 5.5 or 5.1 host's iSCSI VMkernel interface from the SAN itself, or from another ESXi 5.5 or 5.1 host with a VMkernel interface in the same subnet/VLAN.

See Also

This Article Replaces

2041264

Update History

10/03/2013 - Added ESXi 5.5 to products

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 26 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 26 Ratings
Actions
KB: