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vCenter Single Sign-On fails to connect to a Microsoft SQL instance (2039092)

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Symptoms

  • During the installation vCenter Single Sign-On fails to access a remote Microsoft SQL 2008 R2 database.
  • You may see the errors:

    • Login failed for user 'xxx'
    • No Database Name provided

  • Multiple database instances are running on the same Microsoft SQL Server

Cause

By default, the installer tries to access default MS SQL port 1433. However, only the default instance of SQL Server uses this port. By default, all SQL named instances use a dynamic port.

Resolution

To resolve this issue, set the port for the instance to a static port.
 
To set the port for the instance to a static port:
  1. Open the Microsoft SQL Server Configuration Manager.
  2. Navigate to SQL Server Network Configuration > Protocols for the instance name.
  3. Double-click TCP/IP.
  4. Click the IP address tab and scroll to the bottom where you see the dynamic port used by the instance.
  5. Change the port to a static port.

    Note: If it is a dynamic port, it may change if the server is rebooted or if the service is restarted. VMware recommends manually setting a static port number for the instance.

  6. Restart the SQL instance to apply the change.

    Note: From the SSO installer, you do not to specify the port anywhere. The instance accesses the database located in the instance using the configured port.

Additional Information

In the event that you cannot change the port that the SQL Server is listening, you may also change the port vCenter Single Sign-On uses to communicate with SQL Server. For more information, see Updating the vCenter Single Sign-On server database configuration (2045528).

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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