Search the VMware Knowledge Base (KB)
View by Article ID

After reinstalling or upgrading the View agent, the View Administrator console reports the message: Agent Unreachable (2038679)

  • 7 Ratings

Symptoms

  • After reinstalling or upgrading the  agent, the View desktop reports this message on the View Administrator console:

    Agent Unreachable

  • In the View Agent log, you see this entry:

    <YYYY-MM-DD>T<TIME> 789-07:00 DEBUG (0EB8-0F74) <theTopicMessageManager> [AgentJmsConfig] Published CHANGEKEY request

    After approximately 10 seconds, you see this entry:

    <YYYY-MM-DD>T<TIME> 789-07:00 DEBUG (0EB8-0F74) <theTopicMessageManager> [AgentJmsConfig] Timeout waiting for success response

    Note: In the View Agent logs, you may see entries similar to:

    • update rejected, attempt to reconfigure as paired with missing key information
    • FATAL (0324-23C) <572> []The JVM has exited with code 6.
    • INFO (0308-052C) <JavaBridge> wsnm_jms died, restarting in a minute

  • In the Connection Server log, you see the entries similar to:

    <DesktopControlJMS> [JMSMessageSecurity] Message could not be validated: Signature invalid for identity agent
    <DesktopControlJMS> [DesktopTracker] CHANGEKEY message from agent/<Agent GUID> is discarded as it cannot be validated

    Note: For more information on the location of the log files, see Location of VMware View log files (1027744).

Cause

When the View Agent is reinstalled or upgraded, it may change the key pair used to identify the View Agent with the Connection Server.
 
This issue occurs if the process of changing the key in the Connection Server configuration fails and, therefore, causes the communication between the View Agent and Connection Server to break.

Resolution

This is a known issue in VMware View Manager.
 
This issue is resolved in Horizon View 5.2, available at VMware Downloads. For more information about this version, see the VMware Horizon View 5.2 Release Notes. This issue has also been reported in the latest Horizon VIEW editions after 5.2 
 
To work around this issue in pools when you do not want to upgrade:
  1. In the View Administrator console, on the left pane navigate to View Configuration > Global Settings.
  2. Under Security, click Edit.
  3. Ensure that the Message security mode is set to enabled in View admin UI and then run this vdmadmin command:
    Run the command from the location : C:\Program Files\VMware\VMware View\Server\tools\bin

    vdmadmin -A -d desktop-pool-name -m name-of-machine-in-pool -resetkey

    Note: For resetkey to appear in vdmadmin set the key ToolsSupportLevel to 60 by navigating to HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM


Note: This workaround does not apply for View unregistered desktops.

Impact/Risks

Setting the Message security mode option to Mixed or Disabled allows insecure updates to the ADAM database. This was the default behavior for View Manager 5.0 and earlier versions.

Additional Information

Note: Restarting the agent service starts the wsnm_jms process in the desktop where agent service is running. However, the process terminates shortly after starting.
 
To be alerted when this article is updated, click Subscribe to Document in the Actions box.

See Also

Update History

05/24/2013 - Changed resolution section so it reflects the correct path to remove the manual desktop virtual machine. 06/07/2013 - Added information that issue is resolved in View 5.2 and link to VMware download center. 8/4/2014 - Added note under Resolution section 2/24/2016 - Added Notes that indicate this also occurs for the Horizon VIEW 6.1.2 and 6.2 as well as modified title to no longer reflect product specific as it effects multiple product versions

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 7 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 7 Ratings
Actions
KB: