Search the VMware Knowledge Base (KB)
View by Article ID

VMware vSphere Data Protection (VDP) fails with the error: E10056: Restore failed due to existing snapshot (2036109)

  • 23 Ratings
Language Editions

Symptoms

  • When attempting to back up a virtual machine, the process fails with an error shortly after the process begins.

  • In the Task Details, you see the error:

    Execution error: E10056: Restore failed due to existing snapshot. Job Id: <job-id> (Full Client Path:)

  • In the AvVcbImage log file (at the same time as the incident), located at /usr/local/avamarclient/var-proxy-N/Jobname-EPOCH-vmimagew.log, you see the error, indicating that there are no snapshots:

    YYYY-MM-DD 08:52:28 <VM name> Info <16001>: Found 2 disk(s), 0 snapshots, and 4 snapshot ctk files, on the VMs datastore. 

Note: Log file path names are different for different versions of the appliance. You must use the appropriate path:

    • For 5.x : /usr/local/avamarclient/var-proxy-N/*--vmimagew.log
    • For 6.x : /usr/local/avamarclient/var/*--vmimagew.log
       
  • The preceding message is followed by this message. This message states that the snapshots exist:

    YYYY-MM-DD 08:52:28 <VM_Name> Warning <16002>: Too many extra snapshot files (2) were found on the VMs datastore. This can cause a problem for the backup or restore.
    YYYY-MM-DD 08:52:28 <VM_Name> FATAL <16018>: The datastore information from VMX '[VMFS_VOLUME] VM_Name/VM_Name.vmx' will not permit a restore or backup.


    OR

    YYYY-MM-DD 08:52:28 <VM_Name> Info <0000>: Starting graceful (staged) termination, Too many pre-existing snapshots will not permit a restore. (wrap-up stage)
    YYYY-MM-DD 08:52:28 <VM_Name> Error <9759>: createSnapshot: snapshot creation failed


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs when there are no reported snapshots in the VMSD file and/or snapshot manager, but delta files are shown to exist in the actual file structure for the virtual machine.

For example:

-rw-r--r--    1 root     root     0 Sep 24 15:40 VM_Name-000001-delta.vmdk
-rw-r--r--    1 root     root     0 Sep 24 15:32 VM_Name-000001.vmdk


Note: This may also occur when orphaned snapshots are present.

Resolution

Important: The snapshot tree must be carefully followed to ensure that the delta files can be safely relocated without affecting the current state of the virtual machine. Moving a referenced delta may result in unexpected virtual machine behavior.
 
To resolve this issue:

  1. Determine if the snapshots should be consolidated into the base disk, by checking if the snapshot delta is part of the chain and is connecting to the base disk.

  2. To verify if the snapshot delta is part of the chain, use the command:

    #vmkfstools -e Win-2008-1.vmdk -v10.

    Note : If the snapshot delta is connected to the base it is highly recommended that we consolidate the snapshots and not move or rename the snapshot files as just renaming the snapshot files and pointing to the base may cause loss of the data that exist in the delta file itself.

  3. If the snapshot delta is not part of the chain connecting to the base disk then, safely move the file to another folder. For example:

    # mkdir old
    # mv VM_Name-000001*.vmdk old/


  4. Verify that the virtual machine is in an acceptable state.

  5. Permanently remove the files after verification.

  6. Retry the backup process.
Note: This condition was not checked in VMware Data Recovery (VDR) and it is therefore possible that VDR was able to perform a successful backup in this situation. After upgrading however, you may see the messages listed in the Symptoms section.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 23 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 23 Ratings
Actions
KB: