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Connecting from the View Client to a VMware View desktop using PCoIP protocol over a WAN fails with the error: The connection to the remote computer ended (2013003)

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Symptoms

  • Connecting from the View Client to a VMware View desktop using PCoIP protocol over a WAN fails.
  • You see the error:

    The connection to the remote computer ended

  • Connecting using RDP protocol works properly

Cause

This issue occurs due to the blocked UDP port between the View Client and View desktop or an incorrect configuration of the External URL field or PCoIP External URL field.

Resolution

To check if a UDP port is blocked, you need to install netcat for Windows on the View Client, the View Security Server, and the View desktop virtual machine. For more information on netcat and where to download a version for your system, see the Wikipedia netcat page.

Note: The preceding link was correct as of September 1, 2015. If you find the link is broken, provide feedback and a VMware employee will update the link.

Notes:
  • VMware does not endorse or recommend any particular third-party utility, and cannot take responsibility for anything that may occur as a result of the use of a third-party program.
  • To test on the Security Server, first shut down the security server service, as this service is bound to port 4172 and prevents netcat from running.
Using netcat, test the connectivity between each node involved in the connection:
  • To test UDP connectivity from the View desktop to the Security Server:

    1. In a command prompt window on the Security Server, run this command:

      nc -l -u -p 4172

      This sets the Security Server to listen on port 4172 for UDP traffic.

    2. In a command prompt window on the View desktop, run this command:

      nc -u Security_Server_IPaddress 4172

      This transmits traffic over UDP port 4172 to the destination IP address.

    3. Type something in the View desktop command prompt window and click Enter to transmit. If there is connectivity, it appears in the Security Server command prompt window.

  • To test UDP connectivity from the Security Server to the View Desktop virtual machine:

    1. In a command prompt window on the View desktop virtual machine, run this command:

      nc -l -u -p 4172

      This sets the View Desktop to listen on port 4172 for UDP traffic.

    2. In a command prompt window on the Security Server, run this command:

      nc -u View_Desktop_IPaddress 4172

      This transmits traffic over UDP port 4172 to the destination IP address.

    3. Type something in the Security Server command window and click Enter to transmit. If there is connectivity, it appears in the View desktop command prompt window.

  • To test UDP connectivity from the Security Server to the View Client:

    Note: In most environments, this is not practical by firewall administrators as it requires setting firewall rules to redirect an inward port 4172 traffic to the View Client IP address.

    1. In a command prompt window on the View Client, run this command:

      nc -l -u -p 4172

      This sets the View Client to listen on port 4172.

    2. In a command prompt window on the Security Server, run this command:

      nc -u firewall_IPaddress_in_client_environment 4172

      Note: This is possible only if there is an explicit firewall rule to forward 4172 traffic inward to that View Client IP address. This transmits traffic over UDP port 4172 to the destination IP address, which is the View Client IP address behind the firewall.

    3. Type some text in the Security Server command window and click Enter to transmit. If there is connectivity, the entered text appears in the View Client command prompt window.
After testing the connectivity using these steps, if you find that one of the ports is blocked, open the port and re-test to verify.

Note: To verify that netcat is listening for UDP traffic on port 4172, run the netstat -ban command in a command prompt window.

Additional Information

You can also observe UDP packet transmission using a network sniffing tool (for example, Wireshark) on the Security Server or the View Desktop virtual machine.

See Also

Update History

04/02/2013 - Added VMware Horizon View 5.2.x to Products 06/05/2013 - Added comments about required firewall rulesets to the last test section in the Resolutions. 06/27/2013 - Added steps to test UDP connectivity from the Security Server to the View Client

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