Search the VMware Knowledge Base (KB)
View by Article ID

Upgrading to VMware ESXi 5.x fails with the error: Error in ESX configuration file esx.conf (2011588)

  • 3 Ratings

Symptoms

  • You cannot upgrade to VMware ESXi 5.x
  • Upgrading from ESX/ESXi 4.x to ESXi 5.x using Update Manager fails
  • Scanning an ESXi host fails with the error:

    Unsupported Configuration

  • Update Manager reports this error in the Tasks/Events tab in vCenter Server 5.x:

    Error in ESX configuration file esx.conf

  • The vmware-vum-server-log4cpp.log file contains the errors:

    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test 'SUPPORTED_ESX_VERSION', expected '[4, 0] [4, 1]', found '[4, 1]'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test 'SPACE_AVAIL_ISO', expected '312262191', found '312262191'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test 'MEMORY_SIZE', expected '2113929216', found '137432141824'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test 'HARDWARE_VIRTUALIZATION', expected '3', found '3'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test 'CPU_CORES', expected '2', found '8'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test '64BIT_LONGMODESTATUS', expected '1', found '1'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'ERROR', test 'SANE_ESX_CONF', expected 'True', found 'False'
    'HostUpgradeScanner' 5436 INFO] [scannerImpl, 468] Precheck script test result: 'SUCCESS', test 'UNSUPPORTED_DEVICES', expected '', found ''

  • The /var/log/vua.log file on the ESX host contains the errors:

    --> <test>
    --> <name>SANE_ESX_CONF</name>
    --> <expected>
    --> <value>True</value>
    --> </expected>
    --> <found>
    --> <value>False</value>
    --> </found>
    --> <result>ERROR</result>
    --> </test>
    -->
    --> <test>

Cause

During the ESXi 5.x upgrade, a precheck is performed on the ESX/ESXi host to verify compatibility for the upgrade.
The SANE_ESX_CONF portion of the script checks:
  • For the existence of an esxconsole.vmdk in ESX hosts
  • That the /etc/vmware/esx.conf exists with a non-zero size
  • The system UUID based on esxcfg-info output
The most likely cause of the failure is an error returning the system UUID based on the esxcfg-info output.

Resolution


To confirm if this issue is caused by an error returning the system UUID based on the esxcfg-info output, log in to the ESX host and run the command:

esxcfg-info | grep 'System UUID'

Here is an example of valid output that does not indicate a problem:

|----System UUID..............................................4c114aee-494e-8fdf-f9c9-002564fc283e

Here is an example of invalid output that indicates a problem:

Error: No object id found for: vmhba32
The "No object id found for: vmhba32' error message stems from a known issue where the iSCSI database has not been properly upgraded in the past.


To work around this issue, perform one of these options:

  • Perform an upgrade to ESX/ESXi 4.1 Update 2 before upgrading to ESXi 5.0. For more information, see the VMware vCenter Update Manager Installation and Administration Guide. After upgrading to ESX/ESXi 4.1 Update 2, perform the upgrade to ESXi 5.0 using VMware Update Manager. For more information, see Perform an Orchestrated Upgrade of Hosts Using vSphere Update Manager in the vSphere Upgrade Guide.

  • Perform the upgrade to ESXi 5.0 using the CD-ROM or DVD method. For more information, see Download and Burn the ESXi Installer ISO Image to a CD or DVD section in the vSphere Installation and Setup Guide.

Update History

04/23/2013 - Added ESXi 5.1.x to Products

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 3 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 3 Ratings
Actions
KB: