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Provisioning View desktops fails due to customization timeout errors (2007319)

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Symptoms

  • Provisioning View desktops fail
  • You see customization timeout errors
  • There is no network adapter installed on the cloned virtual machines
  • The network adapter is visible in device manager, but the driver is not installed
  • In the View Administrator, you see the error:

    No network communication between the View Agent and Connection Server. Please verify that the virtual desktop can ping the Connection Server via the FQDN

Cause

This issue occurs due to the way the VMXNET 3 adapter is added. The Windows 7 or Windows Server 2008 R2 SP1 Datacenter Edition guest operating system identifies the adapter as a new device and does not properly install the driver during the cloning process.

Resolution

Microsoft has released a hot patch that resolves this issue.

To use the VMXNET 3 adapter, install the hotfix appropriate for the desktop operating system:
  • For Windows 7, see the Microsoft Knowledge Base article 2344941.
  • For Windows 7 SP1 or Windows Server 2008 R2 SP1, see the Microsoft Knowledge Base article 2550978.

Note: The preceding links were correct as of January 15, 2014. If you find a link is broken, provide feedback and a VMware employee will update the link.

To resolve this issue:
  1. Download and install the Windows hotfix patch on the parent virtual machine.
  2. Take a new snapshot of the virtual machine.
    1. Release the IP lease on the virtual machine.
    2. Power off the virtual machine.
    3. In the vSphere Client, click on the virtual machine.
    4. Click Take a snapshot of this virtual machine.
    5. Give the snapshot a name and description.
    6. Click OK.

  3. Recompose the desktop pool:
    1. In the View Manager console, Click Inventory > Pools.
    2. Double-click on the pool you want to recompose.
    3. Click Status and verify that provisioning is enabled for the pool.
    4. Click View Composer > Recompose.
    5. Click on the new snapshot.
    6. Click Next.
    7. Configure the Schedule and Warning options.
    8. Click Next.
    9. Review the confirmation information.
    10. Click Finish.
 
Note: If the View Desktops are using the E1000 adapter instead of the VMXNET3 adapter, you must change the adapter to VMXNET3.
 
To change the network adapter to VMXNET3:
  1. Log in to the vSphere Client.
  2. For linked clone desktops, right-click the parent virtual machine. For full clone desktops, right-click the virtual machine.
  3. Click Edit Settings.
  4. Click the E1000 network adapter and click Remove
  5. Click Add > Ethernet Adapter
  6. For Type, select VMXNET3
  7. Select the correct network to connect to.
  8. Click Next > Finish.
  9. Power on the virtual machine.
  10. For Windows 7 virtual machines, install the appropriate hotfix from Microsoft.

    • For Windows 7, see the Microsoft Knowledge Base article 2344941.
    • For Windows 7 SP1 or Windows Server 2008 R2 SP1, see the Microsoft Knowledge Base article 2550978.

      Note: The preceding links were correct as of January 15, 2014. If you find a link is broken, provide feedback and a VMware employee will update the link.

  11. Uninstall VMware Tools and View Agent, then reinstall VMware Tools and View Agent.
  12. For linked clones, release the IP address, power off the virtual machine, and take a new snapshot.
  13. Recompose the pool using the new snapshot.

See Also

Update History

09/18/2012 - Added contents of 2020627 to this KB and archived 2020627 03/29/2013 - Added VMware Horizon View 5.1.x and 5.2.x to Products 06/10/2013 - Replaced "Windows" with "Windows 7" in the resolution section 01/14/2014 - Added VMware Horizon View 5.3.x to Product Versions. 06/13/2014 - Added info on Windows Server 2008 R2 SP1.

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