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Snapshot of a Windows server fails with the error: Protocol error from VMX (1037071)

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Symptoms

  • Snapshot of a Windows server that has the Quiesced Guest file system option enabled fails
  • Cloning a virtual machine fails 
  • Application-consistent quiescing has been enabled in Windows guest
  • You see the error:

    A general system error occured: Protocol error from VMX.

  • In the vmware.log file, you see the error:

    Toolsbackup: not enough empty nodes (needed <number of attached disks>, found <number of disks>).

    For example:

    vmx| ToolsBackup: not enough empty nodes (needed 8, found 7)

    Where <number of attached disks> is the number of disks attached to the virtual machine.

Cause

The issue occurs when the Windows server has Application-consistent quiescing enabled and the virtual machine has more than 7 disks attached to one SCSI controller.

Resolution

To resolve this issue, use one of these options:
  • Add an additional controller to the virtual machine, so that there are sufficient empty disk nodes on the controllers for the snapshots.

    To add an additional controller when the virtual machine is running, add a new disk and in the Advance Options step, change the Virtual Device Node to use another controller. For example, use SCSI 1 instead of SCSI 0.

    When the virtual machine is down, you can add another controller without adding a new disk. To add another controller, edit the settings of one of the existing disks and change Virtual Device Node to use a different controller.

    For more information on adding an additional controller, see the vSphere Virtual Machine Administration Guide.

  • Disable application-consistent quiescing on guest OS. Set disk.EnableUUID = "FALSE" in the virtual machine configuration file.For more information, see Enabling Windows 2008 application-consistent quiescing on ESX 4.1 (1028881).

Tags

create-snapshot take-snapshot application-consistent protocol error

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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