Search the VMware Knowledge Base (KB)
View by Article ID

VMware Tools may not install on a Windows guest operating system after upgrading to a newer version of ESX/ESXi (1012693)

  • 190 Ratings

Symptoms

  • VMware Tools does not install on a Windows 2008/2003 guest operating system after upgrading to a newer version of ESX/ESXi.
  • Automatic installation of VMware Tools fails.
  • Interactive installation of the VMware Tools tries to uninstall the previous version, but it fails because it cannot reference the previous VMware Tools MSI.
  • You may receive errors similar to:
Error 1316 A network error occurred while attempting to read from the file C:\Windows\Installer\VMware Tools.msi.
 
Error 1706. Setup cannot find the required files.

The installation source for this resource is not available. Verify that the source exists and that you can access it.

Cause

This is an issue with Microsoft Windows Installer and does not affect all Windows 2008/2003 systems. The problem can occur when the original install path from the older version of VMware Tools is invalid, such as if the install path was E:\ and that path is no longer present. For more information, see the Microsoft Knowledge Base article 555175
 
Note: The preceding link was correct as of June 21, 2013. If you find the link is broken, provide feedback and a VMware employee will update the link.

Resolution

To resolve this issue, you must perform a forced uninstall and reinstall of VMware Tools.
 
To uninstall and reinstall VMware Tools:
  1. Right-click the virtual machine and click Guest > Install/Upgrade VMware Tools.
  2. Open a Console to the virtual machine and log into the guest operating system.
  3. Click Start > Run, type cmd, and click OK. A Command Prompt window opens.
  4. Change the drive to your CD-ROM drive (For example, D:\).
  5. Type setup /c and press Enter to force removal of all registry entries and delete the old version of VMware Tools.

    Note: For 64-bit guest operating systems, type setup64 /c

  6. Open My Computer and double-click the CD-ROM that contains VMware Tools.
  7. After Auto-Run starts, follow the prompts to install.

    Note: This must be done from the GUI interface. Do not launch the install by running Setup from the Command Prompt. Also ensure that the CD-ROM is enabled. In the virtual machine properties select CD-ROM under Device Status, and ensure that Connected (if the virtual machine is powered on) and Connect at power on are selected.

  8. When the installation completes, reboot the guest operating system.

Additional Information

Note: These errors can also be generated if Restrict CD-ROM access to locally logged-on user only is enabled via Group Policy within the environment. If this policy has been enabled, consult your Group Policy administrator. 

If this issue persists, file a support request with VMware Support and note this Knowledge Base article ID (1012693) in the problem description. For more information, see Filing a Support Request in My VMware (2006985).

Tags

vmware-tools-upgrade-fails uninstall-vmware-tools manually-uninstall-vmware-tools manually-remove-vmware-tools.

See Also

Update History

04/22/2010 - Indicated that this does not occur on all Microsoft 2008 systems; provided more information about cause. 11/16/2011 - Added ESX/ESXi 4.x and 5.0 to Products 04/17/2012 - Added additional symptom

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 190 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 190 Ratings
Actions
KB: