Search the VMware Knowledge Base (KB)
View by Article ID

VMware Infrastructure Client requires .NET Framework 2.0 to be Installed on 64bit editions of Windows prior to its installation (1004093)

  • 10 Ratings

Details

  • The installation of VMware Infrastructure (VI) Client fails on 64bit operating systems of Windows
  • You see a warning similar to: 

    Setup failed to launch <path of the the VMware-VIClient executable file>

Solution

This issue is resolved in VirtualCenter 2.5 Update 4. For more information, see the VirtualCenter 2.5 Update 4 Release Notes.

Note: If you are experiencing issues using the VI Client with Windows 7 or Windows Server 2008 R2, this issue has been identified in vSphere 4.0 Update 1. For more information, see the vSphere 4.0 Update 1 Release Notes

Prior to VirtualCenter 2.5 Update 4, if the .NET Framework 2.0 is not installed on the 64bit operating system, the VI Client installation fails with a message similar to:
 
Setup has detected that the Microsoft .NET Framework 2.0 pre-requisite is not installed on this system. Please install this pre-requisite and try again.
 

Tags

install-upgrade-vcenter-fails-error install-vsphere-client

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 10 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 10 Ratings
Actions
KB: