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"Machine XXX: No reservation is available to allocate within the group XXX. Total XX GB of storage was requested" error when you request a machine in vRA (2151030)

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Symptoms

  • When you request a machine on vRA it fails.
  • You see an error message similar to:

    The following component requests failed: XXX. Infrastructure service provider error: A server error was encountered. Error requesting machine. Machine XXXXXX: No reservation is available to allocate within the group XXX. Total XX GB of storage was requested.

Cause

As a thumb rule, when the allocated value for the Datastore/Cluster equals the reserved value then no further provisioning would be done on that particular Datastore/Cluster.
Another reason could be when the Storagepath is disabled in database after user disables it and saves it in the GUI. But the GUI does not show the storage path as disabled and user ends up relying on it for provisioning. This leads to insufficient storage reservation in vRA.
 

Resolution

Follow these preliminary steps if a provisioning fails:
 

Check the respective reservation for the business group in question.

  1. Ensure the reservation policy used in the Reservation and that in Blueprint/Catalog request are the same.
  2. Ensure there are sufficient resources available in the reservation.

    1. Verify memory available for allocation. Though if a provisioning fails due to unavailable memory, the error message complains about memory and not storage. For more information, see KB2148620.
    2. Verify storage is available for allocation in the selected Datastore/Storage clusters. If This reservation reserved equals This reservation allocated for a particular Datastore/Cluster then provisioning will not be successful for that Datastore/Cluster.The logic checks for the selected Datastores/Cluster based on the priority assigned to them.
    3. Verify whether Storagepath on the GUI is disabled or not running the query:

      Select * from HostReservationToStorage where [HostReservationID] = ‘<>’ and Enabled = 1


      HostReservationID can be found running the query:


      Select HostReservationID from HostReservation where HostReservationName ='<>'


      If this query does not return anything then the storage path is disabled in GUI. Hence if customer is counting on only this Datastore for provisioning, the provisioning would fail.
    4. Some other scenarios could be related to data mapping issue in database. Which could be a result of datastores/storage cluster being moved around in vCenter. This would need further analysis of the database.
 

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