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Diskgroups fail to mount due to heap exhaustion (2150566)

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Symptoms

  • Following an ESXi host reboot, vSAN diskgroups are not mounted
  • You see the error:

    Heap LSOM already at its maximum size. Cannot expand

Cause

This issue occurs when vSAN does not have enough LSOM memory available to address all disk groups.

For more information about vSAN memory consumption, see Understanding vSAN memory consumption in ESXi 6.5.0d/ 6.0 U3 and later (2113954).

Resolution

To resolve this issue, increase the LSOM heap size to its maximum value, to grant vSAN more memory.

To increase the LSOM heap size:
  1. Open an SSH session to the affected ESXi host:

    • For vSAN 6.2 and later versions, run this command:

      esxcfg-advcfg -s 2047 /LSOM/heapSize

    • For vSAN 6.0 and vSAN 6.1, run this command:

      esxcfg-advcfg -s 1023 /LSOM/heapSize

  2. Reboot the ESXi host.
  3. Repeat for each host in the vSAN cluster.

Additional Information

To find the current LSOM heapsize, run this command to increase the LSOM heap size to it's maximum value:

esxcfg-advcfg -g /LSOM/heapSize

Note: Default heap size is 256 MB.

Tags

diskgroups

See Also

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