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VMware vCloud Automation Center Service fails to start in vRA (2148557)

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Symptoms

  • VMware vCloud Automation Center Service fails to start after applying Windows KB3197874 patch on Windows 2012 R2 Server.
  • In the Repository.log file, you see entries similar to:

    [UTC:2016-11-14 06:29:47 Local:2016-11-14 19:29] [Error]: [sub-thread-Id="34" context="" token=""] System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileLoadException: Could not load file or assembly 'System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

  • In the Windows Application/Events logs, you see entries similar to:

    WebHost failed to process a request.
    Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/34766169
    Exception: System.ServiceModel.ServiceActivationException: The service '/Repository/Data/ManagementModelEntities.svc' cannot be activated due to an exception during compilation. The exception message is: Could not load file or assembly 'System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040). ---> System.IO.FileLoadException: Could not load file or assembly 'System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Cause

This issue is caused because of Microsoft Monitoring Agent version: 8.0.10918.0.

Microsoft Monitoring Agent version: 8.0.10918.0 gets installed as part of the November, 2016 Security Monthly Quality Rollup for Windows Server 2012 R2 (KB3197874) patch.

Resolution

To resolve this issue, use one of these options:
  • Replace the Microsoft Monitoring Agent to a version earlier to 8.0.10918.0.
  • Restore the IaaS server to a state prior to the Microsoft KB3197874 patch.
  • Remove the Microsoft Monitoring Agent.

Note: It is observed that the issue is only reported if you have applied MS updates from November 2016. To mitigate the issue, VMware recommends to apply the latest MS updates.

Additional Information

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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