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Upgrading an ESXi 5.x host through Update Manager fails with an error (2034945)

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Symptoms

  • When using vSphere Update Manager to upgrade an ESXi 5.x host, the remediation fails with the error:

    Software or system configuration of host hostname is incompatible. Check scan results for details.

  • After scanning the host for compliance against an ESXi 5.1 or ESXi 5.5 Upgrade Baseline, the result of the scan shows the host as Incompatible.
  • Clicking on Details for the Upgrade Baseline shows the reason for incompatibility as:

    Host software configuration requires a reboot. Reboot the host and try to upgrade again.

  • The ESXi host is part of, or has been part of, an VMware High Availability (HA) cluster since upgrading vCenter Server to 5.1 or 5.5
  • This issue occurs when using vSphere Update Manager to upgrade from:

    • ESXi 5.0 to ESXi 5.1
    • ESXi 5.0 to ESXi 5.5
    • ESXi 5.1 to ESXi 5.5

Cause

When vCenter Server is upgraded, new versions of the vCenter Server agents (vpxa) are installed on each ESXi host. If the host is also part of a VMware High Availability (HA) cluster, the HA agent (fdm) is also automatically upgraded to the newest vSphere 5.x version that is bundled with vCenter Server. After the HA agent is installed, the host is marked as "Reboot Required" before any further patches or upgrades can be installed.

Resolution

This is a known issue.

This issue is resolved in:
Note: This issue will not be seen when upgrading from the above mentioned versions to a newer version.  Upgrading to the above mentioned versions may still require the workaround below.

To work around this issue, reboot the host before attempting the Remediation:
  1. Place the host into Maintenance Mode. Right-click the host and click Enter Maintenance Mode.
  2. Reboot the host. Right-click the host and click Reboot.
  3. Wait for the host to reconnect to vCenter Server.
  4. In Update Manager, Scan the host again.
  5. After the Scan, verify that the host shows as Noncompliant (red) instead of Incompatible (yellow).
  6. Click Remediate to restart the upgrade.

Additional Information

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See Also

Request a Product Feature

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