Search the VMware Knowledge Base (KB)
View by Article ID

Printers are not mapping to VMware View Client desktop virtual machines (1013520)

  • 21 Ratings
Language Editions

Symptoms

  • Printers are not mapping to VMware View Client desktop virtual machines.
  • Printers are not redirected to VMware View Client desktop virtual machines.

Cause

The View agent is responsible for communication between Client and server. This issue occurs if there is a problem with this communication.

Resolution

Ensure the VMware View agent is operating properly.

To resolve this issue, perform these steps in order. If step 1 does not resolve the issue, proceed to step 2 and so on. Do not skip a step.
  1. Reinstall the VMware View agent. If this step does not solve your issue, proceed to step 2.
  2. Reinstall the VMware View Client on the client PC. If this step does not solve your issue, proceed to step 3.
  3. Stop and start the TP service located in: C:\Program Files\VMware\VMware Tools with these commands:

    tpautoconnect -d (Stop)
    tpautoconnect -v (Start)

    These commands cause the redirection of the printers.

    If this step does not solve your issue, proceed to step 4.

    Note: The following steps modify the Windows registry. Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft Knowledge Base article 136393.

    The preceding link was correct as of April 4, 2016. If you find the link is broken, provide feedback and a VMware employee will update the link.

  4. Increase timeout values in the registry, then reboot the virtual machine. For example:

    Change HKLM\Software\ThinPrint\TPAutoconnect\TimeOutClient from 600000 to 900000
    Change HKLM\Software\ThinPrint\TPAutoconnect\TimeOutClientExecution from 600000 to 900000

    If this step does not solve your issue, proceed to step 5.

  5. Check the registry for names such as "PName_<number>"="<printername>,<value>" from [HKEY_CURRENT_USER\Software\AppDataLow\Software\ThinPrint\Client]. If <value> is set to 0, the printer is not selected to be mapped and you must manually change <value> to 1. For example, change "PName_4"="IBM Proprinter,0" to "PName_4"="IBM Proprinter,1".

See Also

Update History

07/29/2010 - Added View Manager 4.x. 07/10/2013 - Added 4.5,4.6,5.0,5.1 and 5.2 to product versions list. 01/14/2014 - Added Horizon View 5.3 to Product Versions.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 21 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 21 Ratings
Actions
KB: