Search the VMware Knowledge Base (KB)
View by Article ID

升级到 ESXi 5.0 最佳实践 (2030476)

  • 0 Ratings

Symptoms

免责声明:本文为 Best practices for upgrading to ESXi 5.0 (2005102) 的翻译版本。尽管我们会不断努力为本文提供最佳翻译版本,但本地化的内容可能会过时。有关最新内容,请参见英文版本。

Purpose

本文提供了关于升级到 ESXi 5.0 的信息。

注意

Resolution

随着 vSphere 5.0 的引入,ESX 已不再使用。ESXi 是用于数据中心服务器虚化的唯一版本。由于体系架构从 ESX 改变到 ESXi,不能确保所有的配置文件,设置和第三方工具迁移到 ESXi 5.0。请确保您在执行升级前,保留并记录了所有配置更改。更多信息,请参考 vSphere Upgrade Guide

注意:如果虚拟机位于 ESX/ESXi 主机的本地存储上,VMware 强烈建议您在升级前备份这些虚拟机。

当迁移到 ESXi 5.0,请确定:

  1. 您的硬件在VMware Compatibility Guide中是兼容的。这包括:
    • 系统兼容性
    • I/O 兼容性(网络和 HBA 卡)
    • 存储兼容性
    • 备份软件兼容性
  1. 您有一个 64 位处理器。VMware ESXi 5.0 只能安装并运行在 64 位 X86 CPU  的服务器上。它同时仅支持LAHF 和 SAHF CPU 指令。已知的 64 位处理器有:
    • 所有 AMD Opteron 处理器
    • 所有 Intel Xeon 3000/3200、3100/3300、5100/5300、5200/5400、5500/5600、7100/7300、7200/7400 和 7500 处理器
  1. 在主机的 BIOS 中启动 Intel VT。
  2. 您有 2GB 的内存。这是安装的最低要求。
  3. 您有一个或多个千兆或万兆网卡。关于支持的网络适配器型号列表,请参考 VMware Compatibility Guide
  4. 您为虚拟机准备了一个 SCSI 磁盘或本地的,非网络 RAID 卷,并且未分区。对于串行ATA (SATA),是通过支持的 SAS 控制器或支持的板载 SATA 控制器磁盘连接。SATA 磁盘被认为是远程的,而不是本地的。这些磁盘不能用作默认的 scratch 分区,因为他们被认为是远程的。

注意:在一台 ESXi 5.0 主机上,您不能连接一个 SATA CD-ROM 设备到一台虚拟机。要使用 SATA CD-ROM 设备,你必须使用 IDE 模拟模式。

  1. 您正在使用一个受支持的存储系统。ESXi 5.0 支持在如下存储系统上安装并启动:
    • SATA 磁盘启动。支持的板载 SATA 包括:
      • Intel ICH9
      • NVIDIA MCP55
      • ServerWorks HT1000

注意:不支持在多个 ESXi 5.0 间共享 SATA 磁盘 VMFS 数据存储。

    • SATA 磁盘驱动器连接到支持的 SAS 控制器后。支持的 SAS 控制器包括:
      • LSI1068E (LSISAS3442E)
      • LSI1068 (SAS 5)
      • IBM ServeRAID 8K SAS 控制器
      • Smart Array P400/256 控制器
      • Dell PERC 5.0.1 控制器
  1. 你有串行连接 SCSI(SAS)磁盘驱动器。他们支持安装 ESXi 5.0 和在 VMFS 分区上存储虚拟机。
  2. 你有一个专用的光纤 SAN 磁盘或 iSCSI SAN 磁盘。
  3. 你有 USB 设备。他们支持安装 ESXi 5.0。对于支持的 USB 设备列表,请参见 VMware Compatibility Guide

vSphere 5.0 支持从统一可扩展固件接口 (UEFI) 引导 ESXi 主机。使用 UEFI,您可以从硬盘驱动器,CD-ROM 驱动器或 USB 媒体来启动系统。网络引导或使用 VMware Auto Deploy 置备,都需要传统的 BIOS 固件而不是 UEFI。

注意

    • 如果您正在使用的系统固件和任何附加卡上的固件支持,ESXi 可以从大于 2TB 的磁盘启动。欲了解更多信息,请参阅供应商文档。
    • 在您安装 ESXi 5.0 后将启动类型从传统 BIOS 改变到 UEFI,可能会导致主机无法启动。在这种情况下,主机会显示类似如下的错误消息:

Not a VMware boot bank. Changing the host boot type between legacy BIOS and UEFI is not supported after you install ESXi 5.0.

  1. 如果您要将 ESXi 安装在本地磁盘上,并且如果一个光纤 SAN 连接在 ESXi 主机上,请在安装前分离光纤。如果不切断光纤,你可能会不经意地选择某个 HBA 适配器作为主引导分区,这会导致连接到 HBA 适配器上的 LUN 数据丢失。如果您将 ESXi 5.0 安装到 VMFS 卷上,它现在会识别。然而,仍建议您执行此步骤。

注意:请不要在 BIOS 中禁用 HBA 卡

Additional Information

关于升级到 ESXi 5.0 和 vSphere 5.0 新功能的更多信息,请参考 What's New in VMware vSphere 5.0 Platform 技术白皮书。

Tags

简体中文 Simplified Chinese

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.

What can we do to improve this information? (4000 or fewer characters)




Please enter the Captcha code before clicking Submit.
  • 0 Ratings
Actions
KB: